Closed Bug 1527380 Opened 7 months ago Closed 5 months ago

Fission: OOP iframes don't work with webrender picture caching

Categories

(Core :: Graphics, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Fission Milestone M2
Tracking Status
firefox68 --- fixed

People

(Reporter: rhunt, Assigned: rhunt)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files, 1 obsolete file)

I disabled 'tests/dom/ipc/tests/test_force_oop_iframe.html' when we're using webrender to land the oop-iframe patches because of an assertion.

 0:08.50 GECKO(67317) Hit MOZ_CRASH(assertion failed: frame_state.tile_cache.is_none()) at gfx/wr/webrender/src/prim_store/mod.rs:1758

Disabling picture-caching resolved the issue.

Duplicate of this bug: 1530393
No longer depends on: graphics-fission
Summary: Remote iframes don't work with webrender picture caching → Fission: OOP iframes don't work with webrender picture caching

Ryan, are you the correct assignee for this bug?

Blocks: 1528725
Fission Milestone: --- → M2
Flags: needinfo?(rhunt)

It sounds like this is a Gecko integration issue, so I'll look at fixing it.

Assignee: nobody → rhunt
Flags: needinfo?(rhunt)
Status: NEW → ASSIGNED
Attachment #9058394 - Attachment is obsolete: true
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/34062ef2307c
Use BrowsingContext to determine whether a document is top-level content. r=nika
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0939d74e8cb5
Re-enable fission test for WebRender. r=rhunt
Blocks: rendering-fission
No longer blocks: gfx-fission
No longer blocks: graphics-fission
You need to log in before you can comment on or make changes to this bug.