Can't redisplay element which has set display: none on :hover

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Alexander Larsson, Assigned: Peter Linss)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
While looking a bit into doing a CSS2 menu with appearing/disappearing
menu texts using mozilla i ran into a CSS problem.

The problem is that when some content is hidden (display: none) i
can't seem to get it back, because it doesn't seem to match the css selector
rule. This doesn't seem correct.

I'll add a small testcase.
(Reporter)

Comment 1

19 years ago
Created attachment 1931 [details]
Mousing over first line removes the second line. Removing the mouse doesn't make it reappear.
(Reporter)

Comment 2

19 years ago
This works now in a build from 991003.
It seems peter linss latest style change update.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Verified fixed per reporter's comments
You need to log in before you can comment on or make changes to this bug.