[Cards][Lists] Align source and context for SPOCs to bottom of the item container

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
3 months ago

People

(Reporter: wolasi, Assigned: pdahiya)

Tracking

({github-merged})

66 Branch
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66+ verified, firefox67 verified)

Details

Attachments

(2 attachments)

Reporter

Description

3 months ago

Please make the following changes for Cards and Lists

  • The height of items in row should match the height of the tallest item in the row
  • The context for SPOC items and source should be bottom aligned
  • For lists items without excerpts the space between the title and the source (and context for SPOCs should be 4px
  • For cards and list items with excerpts, the minimum spacing between the excerpt and the source (and context for SPOCs should be 8px
  • For lists change square image width and height to 80px

Figma Spec Links

Reporter

Updated

3 months ago
Comment hidden (obsolete)

Updated

3 months ago
Assignee: sdowne → pdahiya
Iteration: --- → 67.1 - Jan 28 - Feb 10
Priority: -- → P1
Reporter

Updated

3 months ago
Summary: [Borderless Cards][Lists] Align source and context for SPOCs to bottom of the item container → [Cards][Lists] Align source and context for SPOCs to bottom of the item container

Comment 3

3 months ago

Looks like bug 1519879 regressed this for cards although lists never had source bottom aligned.

Blocks: 1519879
Keywords: github-merged

Updated

3 months ago
Blocks: 1528410

Comment 4

3 months ago

QA steps:

  1. use dev-test-all (about:config set browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","enabled":true,"show_spocs":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=$apiKey&layout_variant=dev-test-all"})
  2. open a new tab and make sure all source domain text is at the bottom left corner of each item
  3. also check list images are 80px tall

Comment 6

3 months ago
Status: NEW → RESOLVED
Iteration: 67.1 - Jan 28 - Feb 10 → 67.2 - Feb 11 - 24
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (67.0a1 Build ID - 20190217214556) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the source domain text is displayed in the left corner of each item and the check list images are 80px tall.

Status: RESOLVED → VERIFIED

Comment on attachment 9044384 [details]
Bug 1527437 - [Cards][Lists] Align spocs items to bottom of container

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1512725

User impact if declined

User facing bug, user experience is affected

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

QA done

List of other uplifts needed

Bug 1527702

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Small change that has already been tested

String changes made/needed

Attachment #9044384 - Flags: approval-mozilla-beta?

Comment on attachment 9044384 [details]
Bug 1527437 - [Cards][Lists] Align spocs items to bottom of container

OK for uplift for beta 10, mostly css fixes, verified in nightly.

Attachment #9044384 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 11

3 months ago
Flags: needinfo?(marius.coman)

I have verified this issue with the latest Firefox Beta (66.0b10 Build ID - 20190219202808) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the source domain text is displayed in the left corner of each item and the check list images are 80px tall.

Flags: needinfo?(marius.coman)

Updated

3 months ago
See Also: → 1531099
You need to log in before you can comment on or make changes to this bug.