Closed Bug 1527550 Opened 7 months ago Closed 7 months ago

Intermittent [TV] browser/base/content/test/performance/browser_appmenu.js | reflow at adjustArrowPosition@chrome://global/content/bindings/popup.xml was encountered XX times,

Categories

(Firefox :: Menus, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: smaug)

References

Details

(Keywords: intermittent-failure, regression)

#[markdown(off)]
Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=228103955&repo=mozilla-central

https://queue.taskcluster.net/v1/task/TQuJRHe2QDOH254sRe5Sqw/runs/0/artifacts/public/logs/live_backing.log

06:12:11 INFO - TEST-OK | browser/base/content/test/performance/browser_appmenu.js | took 10623ms
06:12:11 INFO - checking window state
06:12:11 INFO - TEST-START | browser/base/content/test/performance/browser_appmenu.js
06:12:12 INFO - TEST-INFO | started process screenshot
06:12:12 INFO - TEST-INFO | screenshot: exit 0
06:12:12 INFO - Buffered messages logged at 06:12:11
06:12:12 INFO - Entering test bound
06:12:12 INFO - TEST-PASS | browser/base/content/test/performance/browser_appmenu.js | The panel is closed to begin with. - "closed" == "closed" -
06:12:12 INFO - Buffered messages logged at 06:12:12
06:12:12 INFO - TEST-FAIL | browser/base/content/test/performance/browser_appmenu.js | known reflow at openPopup/this._openPopupPromise<@resource:///modules/PanelMultiView.jsm was encountered 1 times -
06:12:12 INFO - Full stack:
06:12:12 INFO - openPopup/this._openPopupPromise<@resource:///modules/PanelMultiView.jsm:520:9
06:12:12 INFO -
06:12:12 INFO - Buffered messages finished
06:12:12 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_appmenu.js | reflow at adjustArrowPosition@chrome://global/content/bindings/popup.xml was encountered 23 times,
06:12:12 INFO - it was expected to happen up to 17 times. - false == true - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/performance/head.js :: reportUnexpectedReflows :: line 180
06:12:12 INFO - Stack trace:
06:12:12 INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/head.js:reportUnexpectedReflows:180
06:12:12 INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/head.js:withPerfObserver:637
06:12:12 INFO - chrome://mochitests/content/browser/browser/base/content/test/performance/browser_appmenu.js:null:67
06:12:12 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
06:12:12 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
06:12:12 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:990
06:12:12 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
06:12:12 INFO - Full stack (hit 23 times):
06:12:12 INFO - adjustArrowPosition@chrome://global/content/bindings/popup.xml:290:13
06:12:12 INFO - onxblpopuppositioned@chrome://global/content/bindings/popup.xml:389:9
06:12:12 INFO -
06:12:12 INFO - TEST-FAIL | browser/base/content/test/performance/browser_appmenu.js | known reflow at _calculateMaxHeight@resource:///modules/PanelMultiView.jsm was encountered 7 times -

Bug 1489259 got backed out.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1489259

Bug 1489259 didn't cause anything.

Resolution: DUPLICATE → FIXED
Assignee: nobody → bugs
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.