Closed Bug 1527553 Opened 1 year ago Closed 1 year ago

Update the mozilla-central workspace hack

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: chmanchester, Assigned: chmanchester)

Details

Attachments

(1 file)

We've slid back to recompiling crates in the tree unnecessarily since bug 1499196. There are some syn features that started differing, and there may be others.

We should also figure out how to automatically update this as we update crates in the tree.

Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cabd5a85dc0f
Update the mozilla-central workspace hack. r=firefox-build-system-reviewers,mshal
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

I noticed some big build times improvements on Linux.
I'm not really sure whether they were caused by this bug or bug 1529799, as I'm not really able to retrigger the jobs
on a specific instance type.

== Change summary for alert #19667 (as of Tue, 26 Feb 2019 14:47:41 GMT) ==

Improvements:

16% build times linux64 opt base-toolchains-clang taskcluster-m5d.4xlarge 1,997.82 -> 1,682.56
15% build times linux64 opt base-toolchains-clang taskcluster-m5.4xlarge 2,061.11 -> 1,744.94
15% build times linux64 opt base-toolchains-clang taskcluster-c5.4xlarge 2,025.84 -> 1,721.41
15% build times linux64 opt base-toolchains-clang taskcluster-m4.4xlarge 2,558.96 -> 2,186.44
14% build times linux64 opt base-toolchains-clang taskcluster-c5d.4xlarge 1,891.26 -> 1,628.94
13% build times linux64 opt base-toolchains-clang taskcluster-c4.4xlarge 2,314.11 -> 2,009.47
9% build times linux64 debug plain taskcluster-m5d.4xlarge 1,354.69 -> 1,239.58
8% build times linux64 debug plain taskcluster-c5d.4xlarge 1,288.40 -> 1,188.05
8% build times linux64 debug plain taskcluster-c4.4xlarge 1,641.75 -> 1,515.17
7% build times linux64 debug plain taskcluster-m4.4xlarge 1,774.81 -> 1,657.90
7% build times linux64 pgo taskcluster-c4.4xlarge 5,719.95 -> 5,347.10
6% build times linux64 debug plain taskcluster-c5.4xlarge 1,299.37 -> 1,217.57
6% build times linux64 debug plain taskcluster-m5.4xlarge 1,355.19 -> 1,272.69

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=19667

You need to log in before you can comment on or make changes to this bug.