Closed Bug 1527572 Opened 6 months ago Closed 6 months ago

Download summary button has lost its grey background and top separator

Categories

(Firefox :: Downloads Panel, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- wontfix
firefox66 - verified
firefox67 --- verified

People

(Reporter: bruce.bugz, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR: Have enough downloads (>5) for the downloadsSummary element to show up. A faster, bandwidth-friendly way could be to just add showingsummary="true" to #downloadsFooter. This is how the attached screenshot was taken.

ER: the summary box has a background colour and a separator at the top.

AR: it has neither. Background colour regressed with bug 1515902, separator regressed with bug 1518431.

Blocks: 1515902, 1518431
Keywords: regression

[Tracking Requested - why for this release]:
Visual regression on the downloads panel

Priority: -- → P1
Status: UNCONFIRMED → NEW
Ever confirmed: true

Dão, is this something that you're planning to handle?

Flags: needinfo?(dao+bmo)

I'd likely take uplifts to fix this in beta 66, but don't think I need to track it. I'll notice if a fix lands in nightly and beta is still affected.

Dão, up to you.

Felipe, this is marked as a P1 ("Fix in the current release or iteration" as per our triaging rules https://github.com/mozilla/bug-handling/blob/master/policy/triage-bugzilla.md#how-do-you-triage) can we find somebody to work on this for 67 and potentially uplift to beta 66? If not, then it should probably be marked as a P2 or P3. Thanks.

Flags: needinfo?(felipc)
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(felipc)
Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/affd43bd1637
Properly style the download panel summary. r=Felipe
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Flags: qe-verify+

Comment on attachment 9048497 [details]
Bug 1527572 - Properly style the download panel summary. r?Felipe

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: bug 1515902
  • User impact if declined: see comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: see comment 0
  • List of other uplifts needed: -
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): trivial fix
  • String changes made/needed: -
Attachment #9048497 - Flags: approval-mozilla-beta?

Comment on attachment 9048497 [details]
Bug 1527572 - Properly style the download panel summary. r?Felipe

Fix for style regression in 66, OK for uplift.

Attachment #9048497 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I successfully reproduced the issue on Firefox Nightly 67.0a1 (2019-02-13) under Windows 10 (x64) using the STR from Comment 0.

The issue is no longer reproducible on Firefox Beta 66.0b15 from treeherder (20190310020310) and latest Nightly 67.0a1 (2019-03-10). Tests were performed under Windows 10 (x64), Ubuntu 18.04 (x64) and macOS 10.12.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.