can't paste into apps after mozilla quits

VERIFIED FIXED in M11

Status

()

Core
Editor
P2
major
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: buster, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
using debug build with code from last night (9/29/99) on WinNT, I can copy/paste
from the editor/Gfx text controls just fine.  But if I copy from the editor and
try to paste into another application, nothing happens.
(Reporter)

Updated

19 years ago
Severity: normal → major
Priority: P3 → P2
Summary: copy/paste doesn't work between apps on windows → [regression] copy/paste doesn't work between apps on windows
Target Milestone: M11

Updated

19 years ago
Assignee: akkana → rods

Comment 1

19 years ago
Windows clipboard issue -- assigning to Rod for diagnosis.
(Assignee)

Comment 2

19 years ago
just tried it, and it works for me, however i noticed that sometimes the last
character is dropped. how do we want to deal with this bug in relation to the
last one?
(Assignee)

Updated

19 years ago
Assignee: rods → pinkerton
(Assignee)

Comment 3

19 years ago
please stop assigning these to rod.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
it seems to be a matter of paste not working correctly into other apps after
mozilla has quit. while mozilla is running, paste works perfectly (no chars
dropped, etc).
(Assignee)

Updated

19 years ago
Summary: [regression] copy/paste doesn't work between apps on windows → can't paste into apps after mozilla quits
(Assignee)

Comment 5

19 years ago
i don't think this is a regression, per se, since i'm pretty sure the code hasn't
changed. my bet is that it never worked correctly. we're probably not calling
ForceDataToClipboard() when the app quits on win32.

removing "regression" from the summary and updating to the correct cause.

Comment 6

19 years ago
Yes, I am sure this is not being called because of XP issues. I had it working
at one time, then it got a little confusing about who owned what and when to put
it there etc.

I think the issue was knowning when to do the force to clipboard. Is there
a notification for that, Steve?

Mike, if you want me to help take a look at the Win code on Monday if you want.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
fix checked into the end of main to flush data to the clipboard before app shuts
down.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
works now in 11/ 4 build...I conducted simple test:

copy from ender and paste into windows notepad...
You need to log in before you can comment on or make changes to this bug.