Open Bug 1527637 Opened 2 years ago Updated 1 year ago

Block autoplay does not work

Categories

(Firefox for Android :: General, defect, P2)

55 Branch
ARM
Android
defect

Tracking

()

REOPENED
Tracking Status
firefox-esr68 --- affected
firefox65 --- fix-optional
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- affected
firefox69 --- ?
firefox70 --- ?

People

(Reporter: vincent-moz, Unassigned)

Details

User Agent: Mozilla/5.0 (Android 8.0.0; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

Steps to reproduce:

Open https://www.lyondemain.fr/ludi-relance-lidee-dun-rer-pour-lyon/?utm_source=feedburner&utm_medium=twitter&utm_campaign=Feed%3A+LYFtv+%28LYFtv+Music+and+news%29

Actual results:

I suddenly got sound playing.

Expected results:

Since I have the "Block autoplay" setting, I shouldn't have got any sound.

Hello, I managed to reproduce your issue on the release build (65.0.1) but not on the latest Beta build (66.0b7) and Nightly (67.0a1).
Could you install the latest Nightly build and check if the issue still occurs?

Flags: needinfo?(vincent-moz)
OS: Unspecified → Android
Hardware: Unspecified → ARM
Status: UNCONFIRMED → NEW
Ever confirmed: true

Note that I was using Firefox Beta; see the User Agent line in my report:

User Agent: Mozilla/5.0 (Android 8.0.0; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

Currently, I can no longer reproduce the issue, but Google Play Store says that Firefox Beta was upgraded 9 hours ago, so after I reported the bug.

Flags: needinfo?(vincent-moz)

Resolving this as works for me based on Comment 2 and discussion during Fennec triage.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME

The problem occurs again with Firefox Beta 68.0b11 (on Samsung Galaxy S7) and 68.0b13 (on Gemini). In both cases, I've checked that Settings say "Block autoplay". The problem occurs at least on 20minutes.fr videos. Example:
https://www.20minutes.fr/monde/2549559-20190626-video-presidentielle-americaine-2020-tout-faut-savoir-premier-debat-televise-primaire-democrate

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Adding 68 as affected based on Comment 4.

Hi, issue is reproducible on ESR Firefox Beta 68.1b5 build 1 with device Sony Xperia Z5 (Android 7.0).

You need to log in before you can comment on or make changes to this bug.