Move spidermonkey builds from win32 to win64

RESOLVED FIXED in Firefox 67

Status

()

defect
P1
normal
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: sfink, Assigned: sfink)

Tracking

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

4 months ago

The SM(...) builds are all running on win32, which does not seem like a good idea.

Assignee

Comment 1

4 months ago
Create both win32 and win64 jobs, set run-on-projects to [] for the win32 ones.

Steve, did you forgot asking for a review, or you are still working on it and will request a review later on?

Flags: needinfo?(sphink)
Priority: -- → P1
Assignee

Comment 3

4 months ago

(In reply to Nicolas B. Pierron [:nbp] from comment #2)

Steve, did you forgot asking for a review, or you are still working on it and will request a review later on?

Still working on it, thanks. (It works, but a tier 2 "tg" test is failing even though it works locally, and I don't know if it's the fault of this patch or not.)

Flags: needinfo?(sphink)

(In reply to Steve Fink [:sfink] [:s:] from comment #3)

Still working on it, thanks. (It works, but a tier 2 "tg" test is failing
even though it works locally, and I don't know if it's the fault of this
patch or not.)

"Similar jobs" says you're off the hook.

It seems to be failing precisely on the set of jobs that use try syntax. (Heh, that's one way to nudge... :-/)

Assignee

Comment 6

4 months ago

Yeah, sorry, I tracked it down and fixed it (and yes, it's unrelated to the patch here), but haven't posted it yet because... uh... I was playing around with bzexport and using it as a test case. I'll land both when I'm back at work.

Assignee

Updated

4 months ago
Attachment #9043745 - Attachment is obsolete: true

Comment 8

4 months ago
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/293617cdb29d
Move spidermonkey jobs from win32 to win64 r=jmaher

Comment 9

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Steve, any idea why we're not hitting bug 1527007 with these builds? :)

Flags: needinfo?(sphink)

Oh maybe it's not running on Windows 10?

Assignee

Comment 12

4 months ago

(In reply to Jan de Mooij [:jandem] from comment #10)

Steve, any idea why we're not hitting bug 1527007 with these builds? :)

Because it's not working, it looks like. I'm seeing in the log:

+ python2.7 ./src/js/src/devtools/automation/autospider.py plaindebug
...
++ BITS=32

That autospider.py line should have --platform=win64 in it. Debugging...

Flags: needinfo?(sphink)
Assignee

Comment 13

4 months ago

Bleh. It's because taskcluster's spidermonkey.py duplicates nearly all of the code for non-Windows and Windows, and I didn't notice that so I only made the change in the non-Windows code. :-(

I'm reopening this bug, but I'm assuming it'll fail as expected from bug 1527007 so I'll mark it as depending on that.

Status: RESOLVED → REOPENED
Depends on: 1527007
Resolution: FIXED → ---

Comment 15

4 months ago
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87929b2bb5d1
Apply change to Windows jobs too r=jmaher

Comment 16

4 months ago
bugherder
Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.