QuantumBar: Moving selection to one-off search buttons doesn't update the "Search with" action text

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: standard8, Assigned: adw)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Reporter

Description

4 months ago

STR:

  1. Start typing in the urlbar with something that will result in the first item being "Search with <engine>"
  2. Press alt + arrow down.
  3. As you then navigate through the one-off buttons, observe the "Search with" text.

Expected Results

=> "Search with <engine>" is updated as the one-off button changes.

Actual Results

=> The text is not updated.

This currently causes part of browser_urlbarOneOffs.js to fail.

Assignee

Updated

4 months ago
Duplicate of this bug: 1528408
Assignee

Comment 2

4 months ago

Copying my comment from bug 1528408:

For the awesomebar, it's handled here: https://searchfox.org/mozilla-central/rev/8e8ccec700159dc4efe061cfec2af10b21a8e62a/browser/base/content/urlbarBindings.xml#2642

Not directly related to this bug, but we need to listen for one-off selection changes to properly implement search alias highlighting too.

Assignee

Updated

4 months ago
Blocks: 1491248
Assignee

Updated

4 months ago
Assignee: nobody → adw
Status: NEW → ASSIGNED
Assignee

Comment 4

4 months ago

(In reply to Drew Willcoxon :adw from comment #2)

Not directly related to this bug, but we need to listen for one-off
selection changes to properly implement search alias highlighting too.

Actually we should be hiding the one offs when you use @ aliases, so I guess that's not necessary after all.

Blocks: 1528024
No longer blocks: 1528024

Comment 5

4 months ago
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56992c2597a4
Update search results when the selected one-off button changes. r=dao

Comment 6

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Reporter

Updated

4 months ago
Depends on: 1531295
You need to log in before you can comment on or make changes to this bug.