Closed Bug 1528115 Opened 2 years ago Closed 11 months ago

Remove support for the hidden private window

Categories

(Firefox :: Private Browsing, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: Felipe, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxperf:p3])

Attachments

(1 file)

IIRC, the hidden private window was created a while ago when the page thumbs code needed a private window to take thumbnails, but that has been replaced with loading the page with LOAD_ANONYMOUS.

From a quick search on Searchfox, it looks like nothing else (besides tests) is using the hidden private window anymore. If that's the case, we should drop support for it.

Whiteboard: [fxperf] → [fxperf:p3]
Priority: -- → P3
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db661db8875b
Remove support for the hidden private window; r=bzbarsky
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Assignee: nobody → ehsan
Regressions: 1628200
You need to log in before you can comment on or make changes to this bug.