Intermittent devtools/client/aboutdebugging-new/test/<randomtest>| A promise chain failed to handle a rejection: Connection closed, <more text>

RESOLVED FIXED in Firefox 66

Status

defect
P5
normal
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: dvarga, Assigned: jdescottes)

Tracking

({intermittent-failure})

unspecified
Firefox 67
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed, firefox67 fixed)

Details

Attachments

(3 attachments)

Reporter

Description

4 months ago

#[markdown(off)]

This is still happening on https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&selectedJob=228550034

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=228550034&repo=mozilla-central&lineNumber=2709

18:29:53 INFO - TEST-PASS | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_reload.js | about:devtools-toolbox page displays correctly -
18:29:53 INFO - Removing tab.
18:29:53 INFO - Waiting for event: 'TabClose' on [object XULElement].
18:29:53 INFO - Buffered messages logged at 18:29:49
18:29:53 INFO - Got event: 'TabClose' on [object XULElement].
18:29:53 INFO - Tab removed and finished closing
18:29:53 INFO - Buffered messages logged at 18:29:52
18:29:53 INFO - Removing tab.
18:29:53 INFO - Waiting for event: 'TabClose' on [object XULElement].
18:29:53 INFO - Got event: 'TabClose' on [object XULElement].
18:29:53 INFO - Tab removed and finished closing
18:29:53 INFO - Buffered messages logged at 18:29:53
18:29:53 INFO - Leaving test bound
18:29:53 INFO - Console message: [JavaScript Error: "Error: Connection closed, pending error from root, type listTabs failed" {file: "resource://devtools/server/main.js" line: 1172}]
18:29:53 INFO - Buffered messages finished
18:29:53 INFO - TEST-UNEXPECTED-FAIL | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_reload.js | A promise chain failed to handle a rejection: Connection closed, pending error from root, type listTabs failed - stack: _queueResponse/responsePromise<@resource://devtools/server/main.js:1172:15
18:29:53 INFO - promise callback*_queueResponse@resource://devtools/server/main.js:1170:8
18:29:53 INFO - onPacket@resource://devtools/server/main.js:1295:12
18:29:53 INFO - send/<@resource://devtools/shared/transport/local-transport.js:64:23
18:29:53 INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:22
18:29:53 INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:57:21
18:29:53 INFO - send@resource://devtools/shared/transport/local-transport.js:58:21
18:29:53 INFO - send@resource://devtools/shared/protocol.js:1370:30
18:29:53 INFO - request@resource://devtools/shared/protocol.js:1388:10
18:29:53 INFO - generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol.js:1510:19
18:29:53 INFO - listTabs@resource://devtools/shared/fronts/root.js:189:44
18:29:53 INFO - async*listTabs@resource://devtools/client/aboutdebugging-new/src/modules/client-wrapper.js:123:33
18:29:53 INFO - async*requestTabs/<@resource://devtools/client/aboutdebugging-new/src/actions/debug-targets.js:149:40
18:29:53 INFO - async*thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
18:29:53 INFO - dispatch@resource://devtools/client/shared/vendor/redux.js:755:18
18:29:53 INFO - onTabsUpdated@resource://devtools/client/aboutdebugging-new/src/middleware/debug-target-listener.js:19:11
18:29:53 INFO - emit@resource://devtools/shared/event-emitter.js:186:24
18:29:53 INFO - emit@resource://devtools/shared/event-emitter.js:267:18
18:29:53 INFO - onPacket@resource://devtools/shared/protocol.js:1424:13
18:29:53 INFO - onPacket@resource://devtools/shared/client/debugger-client.js:683:13
18:29:53 INFO - send/<@resource://devtools/shared/transport/local-transport.js:64:23
18:29:53 INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:22
18:29:53 INFO - DevToolsUtils.executeSoon*exports.executeSoon@resource://devtools/shared/DevToolsUtils.js:57:21
18:29:53 INFO - send@resource://devtools/shared/transport/local-transport.js:58:21
18:29:53 INFO - send@resource://devtools/server/main.js:1011:20
18:29:53 INFO - onTabListChanged@resource://devtools/server/actors/root.js:396:15
18:29:53 INFO - BrowserTabList.prototype._notifyListChanged@resource://devtools/server/actors/webbrowser.js:397:10
18:29:53 INFO - BrowserTabList.prototype.handleEvent<@resource://devtools/server/actors/webbrowser.js:585:12
18:29:53 INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:22
18:29:53 INFO - updateCurrentBrowser@chrome://browser/content/tabbrowser.js:1047:14
18:29:53 INFO - _setupEventListeners/<@chrome://browser/content/tabbrowser.js:4573:14
18:29:53 INFO - set selectedIndex@chrome://global/content/elements/tabbox.js:202:12
18:29:53 INFO - set selectedPanel@chrome://global/content/elements/tabbox.js:216:5
18:29:53 INFO - set_selectedIndex@chrome://global/content/bindings/tabbox.xml:176:15
18:29:53 INFO - set_selectedItem@chrome://global/content/bindings/tabbox.xml:201:39
18:29:53 INFO - set selectedTab@chrome://global/content/elements/tabbox.js:81:9
18:29:53 INFO - set selectedTab@chrome://browser/content/tabbrowser.js:266:5
18:29:53 INFO - _blurTab@chrome://browser/content/tabbrowser.js:3248:29
18:29:53 INFO - _beginRemoveTab@chrome://browser/content/tabbrowser.js:2948:10
18:29:53 INFO - removeTab@chrome://browser/content/tabbrowser.js:2856:15
18:29:53 INFO - removeTab@chrome://mochitests/content/browser/devtools/client/shared/test/shared-head.js:191:12
18:29:53 INFO - async*closeAboutDevtoolsToolbox@chrome://mochitests/content/browser/devtools/client/aboutdebugging-new/test/browser/head.js:93:9
18:29:53 INFO - async*@chrome://mochitests/content/browser/devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_reload.js:33:9
18:29:53 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
18:29:53 INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1134:12
18:29:53 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:995:14
18:29:53 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
18:29:53 INFO - Rejection date: Thu Feb 14 2019 18:29:53 GMT-0800 (Pacific Standard Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
18:29:53 INFO - Stack trace:
18:29:53 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
18:29:53 INFO - chrome://mochikit/content/browser-test.js:nextTest:745
18:29:53 INFO - chrome://mochikit/content/browser-test.js:testScope/test_finish/<:1407
18:29:53 INFO - chrome://mochikit/content/browser-test.js:run:1344
18:29:53 INFO - GECKO(826) | MEMORY STAT | vsize 4625MB | residentFast 634MB | heapAllocated 258MB
18:29:53 INFO - TEST-OK | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_reload.js | took 24842ms

Reporter

Updated

4 months ago
Flags: needinfo?(dholbert)
Reporter

Updated

4 months ago
Flags: needinfo?(dholbert)
Reporter

Updated

4 months ago
Flags: needinfo?(jdescottes)
Assignee

Comment 1

4 months ago

This is actually a different issue. The various failures in the other bugs where related to getProcess requests, related to workers. Here the failure is about listTabs, so adding the stack trace and info from the other bug is misleading. Can you update your initial comment to remove the relationship between those bugs?

Flags: needinfo?(jdescottes) → needinfo?(dvarga)
Assignee

Comment 2

4 months ago

We should wait until the selected tab has been updated because we fetch tabs when the selected index changes.

Whiteboard: [retriggered][stockwell disable-recommended]
Assignee

Comment 3

4 months ago

Hard to confirm, re-triggered the suite 400 times to get 2 failures without my patch [1]. With the patch, no failure in 400 re-triggers. [2]

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=8828b6b2937ea59c942240ed925e2af6e6926115
[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=bc900ccd8b9fafae59b7a91ac1030446023d3d03

Assignee

Updated

4 months ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Comment hidden (Intermittent Failures Robot)

Comment 5

4 months ago
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90be1db1879c
Wait for requests to settle after aboutdebugging tab is selected;r=daisuke

Comment 6

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Do you want to request uplift to beta? Or better to let this ride with 67?

Flags: needinfo?(jdescottes)
Assignee

Comment 8

4 months ago

I will uplift this together with Bug 1518581, if we decide to go for an uplift there as well.

Flags: needinfo?(jdescottes)
Duplicate of this bug: 1528103
Duplicate of this bug: 1528415
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 13

4 months ago

Comment on attachment 9045893 [details] [diff] [review]
bug1528140-beta.patch

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: intermittent failures on CI
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Test only change
  • String changes made/needed:
Attachment #9045893 - Flags: approval-mozilla-beta?
Comment on attachment 9045893 [details] [diff] [review]
bug1528140-beta.patch

Test fix, fine for beta 12 uplift.
Attachment #9045893 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment hidden (Intermittent Failures Robot)

Not sure this is fixed.
New intermittent failure on beta: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=232786106&repo=mozilla-beta&lineNumber=2069

22:28:41 INFO - TEST-START | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js
22:28:41 INFO - GECKO(2944) | ++DOCSHELL 0ECCF800 == 14 [pid = 2944] [id = {2120ee89-ea3d-42aa-9f0c-82dec290b3cc}]
22:28:41 INFO - GECKO(2944) | ++DOMWINDOW == 41 (13EDE1B0) [pid = 2944] [serial = 84] [outer = 00000000]
22:28:41 INFO - GECKO(2944) | ++DOMWINDOW == 42 (12C26400) [pid = 2944] [serial = 85] [outer = 13EDE1B0]
22:28:41 INFO - GECKO(2944) | ++DOMWINDOW == 43 (12C23400) [pid = 2944] [serial = 86] [outer = 13EDE1B0]
22:28:41 INFO - GECKO(2944) | --DOMWINDOW == 42 (1828AB40) [pid = 2944] [serial = 80] [outer = 00000000] [url = about:blank]
22:28:41 INFO - GECKO(2944) | --DOMWINDOW == 41 (0B75D670) [pid = 2944] [serial = 64] [outer = 00000000] [url = about:debugging]
22:28:41 INFO - GECKO(2944) | --DOMWINDOW == 40 (1828A550) [pid = 2944] [serial = 52] [outer = 00000000] [url = about:debugging]
22:28:41 INFO - GECKO(2944) | --DOMWINDOW == 39 (0B75D540) [pid = 2944] [serial = 61] [outer = 00000000] [url = about:debugging]
22:28:41 INFO - GECKO(2944) | --DOMWINDOW == 38 (1828AA10) [pid = 2944] [serial = 58] [outer = 00000000] [url = about:debugging]
22:28:41 INFO - GECKO(2944) | --DOMWINDOW == 37 (1828A8E0) [pid = 2944] [serial = 55] [outer = 00000000] [url = about:debugging]
22:28:41 INFO - GECKO(2944) | --DOCSHELL 0E902400 == 13 [pid = 2944] [id = {1190afc9-f2ec-4467-b19d-2889bb7fd42a}]
22:28:42 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: Content used context-fill-opacity when not in a context element: file z:/build/build/src/layout/svg/nsSVGUtils.cpp, line 1497
22:28:43 INFO - GECKO(2944) | --DOMWINDOW == 36 (1828A680) [pid = 2944] [serial = 78] [outer = 00000000] [url = about:blank]
22:28:43 INFO - GECKO(2944) | --DOCSHELL 16518400 == 12 [pid = 2944] [id = {9cda8cf7-8f27-4022-916a-570d1c651d9c}]
22:28:43 INFO - GECKO(2944) | ++DOCSHELL 0E90D000 == 13 [pid = 2944] [id = {0a3c12f9-a944-42ea-b2d2-358d17c8a460}]
22:28:43 INFO - GECKO(2944) | ++DOMWINDOW == 37 (0B75D540) [pid = 2944] [serial = 87] [outer = 00000000]
22:28:43 INFO - GECKO(2944) | ++DOMWINDOW == 38 (12C2EC00) [pid = 2944] [serial = 88] [outer = 0B75D540]
22:28:43 INFO - GECKO(2944) | ++DOMWINDOW == 39 (17BE6400) [pid = 2944] [serial = 89] [outer = 0B75D540]
22:28:43 INFO - GECKO(2944) | ++DOMWINDOW == 40 (12C27000) [pid = 2944] [serial = 90] [outer = 0B75D540]
22:28:43 INFO - GECKO(2944) | --DOMWINDOW == 7 (084B9000) [pid = 5188] [serial = 24] [outer = 00000000] [url = moz-extension://1a83b1ca-8d7a-4cf6-95dc-a9723956d244/_generated_background_page.html]
22:28:43 INFO - GECKO(2944) | --DOMWINDOW == 6 (084AE400) [pid = 5188] [serial = 23] [outer = 00000000] [url = about:blank]
22:28:43 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file z:/build/build/src/dom/base/nsContentUtils.cpp, line 3770
22:28:44 INFO - GECKO(2944) | ++DOCSHELL 1803FC00 == 14 [pid = 2944] [id = {fe1fd543-0151-46ce-b39b-69d71138d549}]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 41 (13EDE2E0) [pid = 2944] [serial = 91] [outer = 00000000]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 42 (18064800) [pid = 2944] [serial = 92] [outer = 13EDE2E0]
22:28:44 INFO - GECKO(2944) | ++DOCSHELL 0F2A7C00 == 15 [pid = 2944] [id = {68bb9a5d-8175-4b63-b98b-fec8e390f097}]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 43 (13EDE540) [pid = 2944] [serial = 93] [outer = 00000000]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 44 (0F2A8400) [pid = 2944] [serial = 94] [outer = 13EDE540]
22:28:44 INFO - GECKO(2944) | ++DOCSHELL 13B58000 == 16 [pid = 2944] [id = {38b7721f-01b9-4211-9d69-8c831bfc39da}]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 45 (13EDE670) [pid = 2944] [serial = 95] [outer = 00000000]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 46 (17760000) [pid = 2944] [serial = 96] [outer = 13EDE670]
22:28:44 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x80004005: file z:/build/build/src/docshell/shistory/nsSHistory.cpp, line 1198
22:28:44 INFO - GECKO(2944) | ++DOCSHELL 0F2AC800 == 17 [pid = 2944] [id = {6c2bb636-d85e-4936-8bb6-14e5aacbed62}]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 47 (13EDE7A0) [pid = 2944] [serial = 97] [outer = 00000000]
22:28:44 INFO - GECKO(2944) | ++DOMWINDOW == 48 (0F2B3400) [pid = 2944] [serial = 98] [outer = 13EDE7A0]
22:28:45 INFO - GECKO(2944) | --DOMWINDOW == 2 (00D67400) [pid = 1900] [serial = 8] [outer = 00000000] [url = about:blank]
22:28:46 INFO - GECKO(2944) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 47 (18EDB000) [pid = 2944] [serial = 79] [outer = 00000000] [url = about:blank]
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 46 (0ECDA400) [pid = 2944] [serial = 66] [outer = 00000000] [url = about:debugging]
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 45 (17462400) [pid = 2944] [serial = 63] [outer = 00000000] [url = about:debugging]
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 44 (1803C400) [pid = 2944] [serial = 60] [outer = 00000000] [url = about:debugging]
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 43 (1A54FC00) [pid = 2944] [serial = 57] [outer = 00000000] [url = about:debugging]
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 42 (12C30000) [pid = 2944] [serial = 54] [outer = 00000000] [url = about:debugging]
22:28:47 INFO - GECKO(2944) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
22:28:47 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: Content used context-fill-opacity when not in a context element: file z:/build/build/src/layout/svg/nsSVGUtils.cpp, line 1497
22:28:47 INFO - GECKO(2944) | --DOMWINDOW == 4 (07EC7C00) [pid = 1640] [serial = 11] [outer = 00000000] [url = about:blank]
22:28:47 INFO - GECKO(2944) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
22:28:47 INFO - GECKO(2944) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
22:28:48 INFO - GECKO(2944) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
22:28:48 INFO - GECKO(2944) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x80004005: file z:/build/build/src/docshell/shistory/nsSHistory.cpp, line 1198
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, false) failed with result 0x80004005: file z:/build/build/src/docshell/shistory/nsSHistory.cpp, line 1198
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_TRUE(mDoneSetup) failed: file z:/build/build/src/editor/composer/nsEditingSession.cpp, line 1225
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_SUCCESS(EnsureScriptEnvironment(), nullptr) failed with result 0x80040111: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 3601
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_TRUE(doc) failed: file z:/build/build/src/dom/base/Location.cpp, line 824
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_TRUE(!mIsBeingDestroyed) failed: file z:/build/build/src/docshell/base/nsDocShell.cpp, line 8570
22:28:48 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/dom/base/Location.cpp, line 228
22:28:48 INFO - GECKO(2944) | console.warn: "Error while detaching the thread front: No such actor for ID: server1.conn1.child1/context22"
22:28:48 INFO - GECKO(2944) | --DOCSHELL 00E67000 == 1 [pid = 1640] [id = {3f8313b1-7d86-4c56-88e3-7113f56ac608}]
22:28:48 INFO - GECKO(2944) | --DOMWINDOW == 3 (07E012E0) [pid = 1640] [serial = 12] [outer = 00000000] [url = about:blank]
22:28:49 INFO - GECKO(2944) | --DOMWINDOW == 41 (18A34400) [pid = 2944] [serial = 81] [outer = 00000000] [url = about:blank]
22:28:49 INFO - GECKO(2944) | --DOMWINDOW == 40 (0F202400) [pid = 2944] [serial = 65] [outer = 00000000] [url = about:blank]
22:28:49 INFO - GECKO(2944) | --DOMWINDOW == 39 (12C2B000) [pid = 2944] [serial = 68] [outer = 00000000] [url = about:blank]
22:28:49 INFO - GECKO(2944) | --DOMWINDOW == 38 (14133C00) [pid = 2944] [serial = 71] [outer = 00000000] [url = about:blank]
22:28:49 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_TRUE(mDoneSetup) failed: file z:/build/build/src/editor/composer/nsEditingSession.cpp, line 1225
22:28:49 INFO - GECKO(2944) | console.error: "[ACTION FAILED] REQUEST_TABS_FAILURE: Connection closed, pending request to root, type listTabs failed\n\nRequest stack:\nrequest@resource://devtools/shared/protocol.js:1415:14\ngenerateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol.js:1539:14\nlistTabs@resource://devtools/shared/fronts/root.js:180:38\nlistTabs@resource://devtools/client/aboutdebugging-new/src/modules/client-wrapper.js:108:12\nrequestTabs/<@resource://devtools/client/aboutdebugging-new/src/actions/debug-targets.js:143:26\nthunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9\ndispatch@resource://devtools/client/shared/vendor/redux.js:755:18\nonTabsUpdated@resource://devtools/client/aboutdebugging-new/src/middleware/debug-target-listener.js:19:5\nemit@resource://devtools/shared/event-emitter.js:186:15\nemit@resource://devtools/shared/event-emitter.js:267:5\nonPacket@resource://devtools/shared/protocol.js:1453:7\nonPacket@resource://devtools/shared/client/debugger-client.js:770:7\nsend/<@resource://devtools/shared/transport/local-transport.js:64:11\nexports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14\ncallFunctionWithAsyncStack@resource://devtools/shared/platform/stack.js:61:10\nexecutor@resource://devtools/shared/DevToolsUtils.js:59:9\nexports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14\n"
22:28:49 INFO - GECKO(2944) | console.error: "destroy@resource://devtools/shared/protocol.js:1328:23\ndestroy@resource://devtools/shared/protocol.js:952:9\ncleanup@resource://devtools/shared/protocol.js:966:5\nonClosed@resource://devtools/shared/client/debugger-client.js:917:7\nclose@resource://devtools/shared/transport/local-transport.js:154:9\nclose@resource://devtools/shared/transport/local-transport.js:150:7\nclose@resource://devtools/shared/transport/local-transport.js:150:7\ncleanup@resource://devtools/shared/client/debugger-client.js:300:9\ndetachClients@resource://devtools/shared/client/debugger-client.js:325:9\nclose@resource://devtools/shared/client/debugger-client.js:339:5\nclose@resource://devtools/client/aboutdebugging-new/src/modules/client-wrapper.js:136:12\ndisconnectRuntime/<@resource://devtools/client/aboutdebugging-new/src/actions/runtimes.js:147:13\n"
22:28:49 INFO - GECKO(2944) | [Parent 2944, Main Thread] WARNING: NS_ENSURE_TRUE(currentInner) failed: file z:/build/build/src/dom/base/WindowDestroyedEvent.cpp, line 107
22:28:49 INFO - GECKO(2944) | JavaScript error: resource://devtools/server/main.js, line 1179: Error: Connection closed, pending error from root, type listTabs failed
22:28:49 INFO - TEST-INFO | started process screenshot
22:28:49 INFO - TEST-INFO | screenshot: exit 0
22:28:49 INFO - Buffered messages logged at 22:28:41
22:28:49 INFO - Entering test bound
22:28:49 INFO - Force all debug target panes to be expanded
22:28:49 INFO - opening about:debugging
22:28:49 INFO - Adding a new tab with URL: about:debugging
22:28:49 INFO - Tab added and finished loading
22:28:49 INFO - wait for the initial about:debugging requests to be successful
22:28:49 INFO - Buffered messages logged at 22:28:43
22:28:49 INFO - Show about:devtools-toolbox page
22:28:49 INFO - TEST-PASS | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js | about:debugging tab target appeared -
22:28:49 INFO - TEST-PASS | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js | Inspect button for about:debugging appeared -
22:28:49 INFO - Buffered messages logged at 22:28:47
22:28:49 INFO - Wait for about:devtools-toolbox tab will be selected
22:28:49 INFO - Check whether the menu item which opens devtools is disabled
22:28:49 INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: gContextMenuContentData
22:28:49 INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: SpellCheckHelper
22:28:49 INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: LoginHelper
22:28:49 INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: LoginManagerContextMenu
22:28:49 INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: DevToolsShim
22:28:49 INFO - TEST-PASS | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js | "hidden" attribute of #context-inspect should be correct -
22:28:49 INFO - Force to select about:debugging page
22:28:49 INFO - Check whether the menu item which opens devtools is enabled
22:28:49 INFO - TEST-PASS | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js | "hidden" attribute of #context-inspect should be correct -
22:28:49 INFO - Buffered messages logged at 22:28:48
22:28:49 INFO - Removing tab.
22:28:49 INFO - Waiting for event: 'TabClose' on [object XULElement].
22:28:49 INFO - Got event: 'TabClose' on [object XULElement].
22:28:49 INFO - Tab removed and finished closing
22:28:49 INFO - Buffered messages logged at 22:28:49
22:28:49 INFO - Removing tab.
22:28:49 INFO - Waiting for event: 'TabClose' on [object XULElement].
22:28:49 INFO - Got event: 'TabClose' on [object XULElement].
22:28:49 INFO - Tab removed and finished closing
22:28:49 INFO - Leaving test bound
22:28:49 INFO - Buffered messages finished
22:28:49 INFO - TEST-UNEXPECTED-FAIL | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js | A promise chain failed to handle a rejection: Connection closed, pending error from root, type listTabs failed - stack: _queueResponse/responsePromise<@resource://devtools/server/main.js:1179:15
22:28:49 INFO - Rejection date: Fri Mar 08 2019 22:28:49 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
22:28:49 INFO - Stack trace:
22:28:49 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
22:28:49 INFO - chrome://mochikit/content/browser-test.js:nextTest:747
22:28:49 INFO - Console message: [JavaScript Error: "Error: Connection closed, pending error from root, type listTabs failed" {file: "resource://devtools/server/main.js" line: 1179}]
22:28:49 INFO - GECKO(2944) | MEMORY STAT | vsize 847MB | vsizeMaxContiguous 626MB | residentFast 316MB | heapAllocated 116MB
22:28:49 INFO - TEST-OK | devtools/client/aboutdebugging-new/test/browser/browser_aboutdebugging_devtoolstoolbox_contextmenu.js | took 8172ms

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

3 months ago
Flags: needinfo?(balbeza)
Comment hidden (Intermittent Failures Robot)

Thanks for the warning, :daisuke is now investigating this.

Flags: needinfo?(balbeza) → needinfo?(dakatsuka)

Comment 23

3 months ago
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ebdf6023eb76
Wait for removing about:devtools-toolbox tab info from about:debugging. r=ladybenko

Comment 24

3 months ago
bugherder
Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.