fonts get corrupted at random

RESOLVED WORKSFORME

Status

()

Core
Layout
P4
minor
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Timofey Vorobyov, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; ru-RU; rv:1.0.0) Gecko/20020602
BuildID:    2002060216

text changes fonts at random when it re-appears after menu browsing or switching
back from another window. The display can be turned back to normal by scrolling
the corrupt area away from the screen and back.

Reproducible: Sometimes
Steps to Reproduce:
1.Open a page that contains a lot of text in small fonts
2.use RMB or open another window that overlaps with Mozilla
3.return to the browser

Actual Results:  fonts in the redrawn window area may differ from the resto of
the page

Expected Results:  fonts should be the same

Operating system extra details: OS/2 Warp Server for e-Business FP2, Matrox
Millenium with native drivers, native fonts

Comment 1

16 years ago
Can you post a screenshot please?

Comment 2

16 years ago
And this web page is invalid

Updated

16 years ago
QA Contact: petersen → moied
(Reporter)

Comment 3

16 years ago
Created attachment 88451 [details]
Screenshot of corrupt display (different URL)

Note the corrupted area in the red box.
Seems to be difficult to reproduce.
I have not observed this behavior on 0.9.x builds
(Reporter)

Comment 4

16 years ago
Created attachment 88462 [details]
Another corrupt display screenshot

This is a screenshot of corrupt display from http://musica.mustdie.ru/ru/mboard
(managed to reproduce it). Have a look at the bottom of the screen
(Reporter)

Comment 5

16 years ago
Created attachment 88463 [details]
Normal display for attachment #2 [details] [diff] [review]

This screenshot was obtained from #2 by scrolling the window up and down,
making the corrupt items at the bottom disappear and re-appear on screen

Comment 6

16 years ago
I've seen this problem occasionally on CNN Web Pages, where the font would
suddenly change, frequently right in the middle of a word and last for one or
two lines.  But it appears randomly and is difficult to reproduce.

So, Timofey, you are not alone.

Hope it eventually gets found. 

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
(Reporter)

Comment 7

16 years ago
Created attachment 88620 [details]
Another corrupt screenshot

Notice that here font gets bold, where it should be normal (see next
screenshot)
(Reporter)

Comment 8

16 years ago
Created attachment 88621 [details]
Normal display for  attachment #4 [details] [diff] [review] (88620)

This is what should have been displayed

Updated

16 years ago
Target Milestone: --- → Future
Timofey:  There have been been many changes to fonts made in the code since this
bug was filed.  Have you seen this issue with any of the latest builds?
(Reporter)

Comment 10

16 years ago
Still persists in 1.2 (Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2.1)
Gecko/20021201). Moreover, sometimes corruption not only applies to font
appearance, but to display codepage for corrupted entries (i.e. they appear in a
different codepage from the rest of the text which is ok). However, corruption
usually does not apply to a portion of plain text, but to headers/bold items,
etc., as if a css table is corrupt (I will try to make a screenshot as soon as
it appears). Perhaps it is a different bug??

Comment 11

15 years ago
We fixed a major presentation space problem recently. Can you check and see if
you still see this on a current build?

Thanks

Comment 12

15 years ago
Please check this with 1.4rc1. If I hear no response, I will close in a week.

Comment 13

15 years ago
Week is up.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.