Closed Bug 1528499 Opened 8 months ago Closed 8 months ago

Perma toolchains-clang make: *** [configure] Error 1 - when Gecko 67 merges to Beta on 2019-03-11

Categories

(Firefox Build System :: Toolchains, defect)

defect
Not set

Tracking

(firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

VERIFIED FIXED
mozilla67
Tracking Status
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: NarcisB, Assigned: glandium)

References

Details

Attachments

(1 file)

Central as Beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=7cc2d6c073df873d0a8990f70eefbda1cf86ecc8

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=228825966&repo=try&lineNumber=1260

Log snippet:

[task 2019-02-16T13:23:39.592Z] 13:23:39 INFO - checking for -pipe support... yes
[task 2019-02-16T13:23:39.653Z] 13:23:39 INFO - checking what kind of list files are supported by the linker... configure: error: Couldn't find one that works
[task 2019-02-16T13:23:39.660Z] 13:23:39 INFO - DEBUG: <truncated - see config.log for full output>
[task 2019-02-16T13:23:39.660Z] 13:23:39 INFO - DEBUG: configure:11322: /builds/worker/workspace/build/src/clang/bin/clang++ -std=gnu++14 -c -I/builds/worker/workspace/build/src/clang/include -fPIC -Qunused-arguments -fPIC -fvisibility-inlines-hidden -Wall -W -Wno-unused-parameter -Wwrite-strings -Wcast-qual -Wmissing-field-initializers -pedantic -Wno-long-long -Wcovered-switch-default -Wnon-virtual-dtor -Wdelete-non-virtual-dtor -Wstring-conversion -Werror=date-time -std=c++11 -fcolor-diagnostics -ffunction-sections -fdata-sections -O3 -DNDEBUG -fno-exceptions -fno-rtti -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -DHAVE_NEW_ASTMATCHER_NAMES conftest.C 1>&5
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11476: checking for __cxa_demangle
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11511: /builds/worker/workspace/build/src/clang/bin/clang++ -std=gnu++14 -o conftest -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 conftest.C -ldl 1>&5
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11573: checking for unwind.h
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11586: /builds/worker/workspace/build/src/clang/bin/clang++ -std=gnu++14 -c -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong conftest.C 1>&5
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11603: checking for _Unwind_Backtrace
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11640: /builds/worker/workspace/build/src/clang/bin/clang++ -std=gnu++14 -o conftest -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 conftest.C -ldl 1>&5
[task 2019-02-16T13:23:39.661Z] 13:23:39 INFO - DEBUG: configure:11722: checking for -pipe support
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: configure:11752: checking what kind of list files are supported by the linker
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: configure:11757: /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o conftest.o -c -flto=thin -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong conftest.c 1>&5
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: configure:11764: /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o conftest -flto=thin -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 conftest.list -ldl 1>&5
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: conftest.o: file not recognized: File format not recognized
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: clang-4.0: error: linker command failed with exit code 1 (use -v to see invocation)
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: configure:11768: /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o conftest -flto=thin -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 -Wl,-filelist,conftest.list -ldl 1>&5
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: /usr/bin/ld: -f may not be used without -shared
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: clang-4.0: error: linker command failed with exit code 1 (use -v to see invocation)
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: configure:11770: /builds/worker/workspace/build/src/clang/bin/clang -std=gnu99 -o conftest -flto=thin -lpthread -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions -Wl,--build-id=sha1 @conftest.list -ldl 1>&5
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: conftest.o: file not recognized: File format not recognized
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: clang-4.0: error: linker command failed with exit code 1 (use -v to see invocation)
[task 2019-02-16T13:23:39.662Z] 13:23:39 INFO - DEBUG: configure: error: Couldn't find one that works
[task 2019-02-16T13:23:39.663Z] 13:23:39 INFO - ERROR: old-configure failed
[task 2019-02-16T13:23:39.698Z] 13:23:39 INFO - *** Fix above errors and then restart with
[task 2019-02-16T13:23:39.698Z] 13:23:39 INFO - "./mach build"
[task 2019-02-16T13:23:39.698Z] 13:23:39 INFO - client.mk:111: recipe for target 'configure' failed
[task 2019-02-16T13:23:39.698Z] 13:23:39 INFO - make: *** [configure] Error 1
[task 2019-02-16T13:23:39.757Z] 13:23:39 ERROR - Return code: 2
[task 2019-02-16T13:23:39.757Z] 13:23:39 WARNING - setting return code to 2
[task 2019-02-16T13:23:39.757Z] 13:23:39 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
[task 2019-02-16T13:23:39.757Z] 13:23:39 FATAL - Running post_fatal callback...
[task 2019-02-16T13:23:39.758Z] 13:23:39 FATAL - Exiting -1

The problem is the base-toolchain jobs are forced into being PGO on beta, when they never were meant to be.

Assignee: nobody → mh+mozilla
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e48a5648d067
Don't PGO the base-toolchain tasks on release branches. r=ted
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
See Also: → 1534272
You need to log in before you can comment on or make changes to this bug.