Open in New Tab option in Private Browsing Window Opens New Public Window rather than New Private Tab in Active Window

UNCONFIRMED
Unassigned

Status

()

defect
UNCONFIRMED
5 months ago
5 months ago

People

(Reporter: ryansinn, Unassigned)

Tracking

66 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Open a private window

Right click on a link on a webpage

The primary two options are:
'Open Link in New Tab'
and
'Open Link in New Private Window'

Open link in New Tab opens a new NON-PRIVATE Window (not a new tab)
Open Link in New Private window

Actual results:

The primary two options are:
'Open Link in New Tab'
and
'Open Link in New Private Window'

Open link in New Tab opens a new NON-PRIVATE Window (not a new tab in the existing window)
Open Link in New Private window opens a new Private Window

Expected results:

There should be a "Open in new PRIVATE tab" to compliment the New Private Window AND the fact you're opening the link from an EXISTING private window/tab.

MIDDLE-CLICKing (3rd button) a link in a Private Browser Window opens the link in a NEW private tab in the active window.

The middle click functionality is not available through the context menu.

Summary: Open in New Private Tab option missing from right click context menu → Open in New Private Tab option missing from Private Window right click context menu
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648517

I think I'm being misunderstood.

Bug #648517 is not a duplicate.
That is a request for private and non-private tabs on the same window.

I will try to articulate the issue more clearly below:

I'm saying that the 'private tab' option is missing from the context menu.

It's confusion and other browsers (Edge, Chrome, Opera) all offer both tab and window options in the context menu.

The functionality is there because MIDDLE (3rd) BUTTON CLICKING on a link opens a new private tab. CTRL+T opens a new private tab, but using the context menu opens a new public tab. It's not predictable or conforming behavior.
If it was CRTL+T should open a new public tab, but it doesn't

Public Window: CTRL+T = New Public Tab
Public Window: MIDDLE CLICK on page link = New Public Tab in same window
Public Window: New Public TAB - Context menu opens new public window.

Private Window: CTRL+T = New Private Tab in same window
Private Window: MIDDLE CLICK on page link = New Private Tab in same window
Private Window: Right click context menu - Open in New Tab - opened new Public Window

I restarted the browser and could not reproduce this behavior, but I reproduced it numerous times and was so surprised by the behavior that I opened the bug.

Sorry - not that the 'Open in private tab' option was missing , but that the 'Open in New Tab' option in the right-click context menu of a private browsing window as opening new public windows rather than new tabs in the private browsing window.

I tried to the feature multiple times without closing the New Public Browsing Window that clicking on 'open in new tab' had created and clicking 'open in new tab' multiple times would create a new public browsing window each time rather than stack the new tabs being requested in the same public browsing window.

Summary: Open in New Private Tab option missing from Private Window right click context menu → Open in New Tab option in Private Browsing Window Opens New Public Window rather than New Private Tab in Active Window

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
20190214195736

(In reply to ryansinn from comment #2)

I'm saying that the 'private tab' option is missing from the context menu.

It's not missing. It's just called "Open Link in New Tab". See bug 1432119.

using the context menu opens a new public tab.

I can't reproduce this.

Status: RESOLVED → UNCONFIRMED
Component: Untriaged → Private Browsing
Resolution: DUPLICATE → ---

Selecting "open in new tab" from a private browsing window opens a new tab in the same private browsing window on my system with Firefox 65+67.

Right Matthias - that's the behavior I was expecting, but instead 'open in new tab' was opening new windows... and not like one new window but a new window each time I would select 'open in new tab'

This happened after a fresh install of Windows 10 and I've never had this issue before (or since) -- I will report back again if it occurs again. I will also screen record it if I can.

You need to log in before you can comment on or make changes to this bug.