Browser does not understand css files with php extension

VERIFIED INVALID

Status

()

Core
DOM: CSS Object Model
--
minor
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Henning Schaefer, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
The browser seems to not understand <LINK REL=STYLESHEET> - tags where the used 
stylesheet is not a *.css file, but a *.css.php3 file taking some parameters 
(e.g. the font to be used) to generate the final stylesheet (which is a correct 
css 2.0 sheet). The browser seems to ignore the file and its contents 
completely, while this works fine with other browsers. After having renamed 
the .css.php3 file into .css, everything works fine, but I have lost the 
capability of dynamically generating the required file.
Make sure you PHP is sending back a "Content-Type: text/css" header and not a
"Content-Type: text/html" header. If it is sent back as text/html then we ignore
it because we don't know how to handle text/html stylesheets.

Comment 2

16 years ago
That does in fact seem to be the problem:

> HTTP/1.1 200 OK
> Date: Wed, 19 Jun 2002 20:05:19 GMT
> Server: Apache/1.3.23 (Unix) PHP/4.1.2 mod_ssl/2.8.7 OpenSSL/0.9.6b
> X-Powered-By: PHP/4.1.2
> Connection: close
> Content-Type: text/html
Solution: get your PHP script to send the correct content-type (text/css) for the 
stylesheet (and the correct charset, if possible). INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.