Closed Bug 1528756 Opened 1 year ago Closed 1 year ago

Crash on @ poll

Categories

(Core :: Networking, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1516325
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fix-optional
firefox68 --- fixed

People

(Reporter: sommerquentin67, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Regular usage.

Actual results:

Started crashing semi-regularly (sometimes more than once a day). since a week or so. Happens on Linux and mac os.

Symptoms are: pages stop responding to clicks, new tab stop loading (stick in blank page state) then Firefox crashes.

66.0b8 (64 bits)

crash report
bp-962e2ff8-44ea-4524-a5e7-3ede00190218

Expected results:

no crash

This bug is for crash report bp-962e2ff8-44ea-4524-a5e7-3ede00190218.

Top 10 frames of crashing thread:

0 libnss3.dylib poll nsprpub/pr/src/md/unix/unix.c:3780
1 XUL mozilla::net::nsSocketTransportService::Run netwerk/base/nsSocketTransportService2.cpp:552
2 XUL non-virtual thunk to mozilla::net::nsSocketTransportService::Run netwerk/base/nsSocketTransportService2.cpp
3 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1161
4 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:474
5 XUL mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:333
6 XUL nsThread::ThreadFunc ipc/chromium/src/base/message_loop.cc:315
7 libnss3.dylib _pt_root nsprpub/pr/src/pthreads/ptthread.c:201
8 libsystem_pthread.dylib _pthread_body 
9 libsystem_pthread.dylib _pthread_start 

Status: UNCONFIRMED → NEW
Crash Signature: [@ poll]
Ever confirmed: true
Keywords: crash

Seems to be all Mac crashes, which go back to before 65. Some comments:

  • i was scrolling through twitter and the browser closed
  • crashed when I pressed ‘restart firefox’ after submitting my last crash report. It crashed prior due to the new twitter layout (has happened like 10 times)
  • this crash has happened like 4 times, and I think it’s the new twitter browser layout/update that was rolled out maybe 2 weeks ago. It can crash when scrolling my feed, or in another tab

On Nightly, there is a strong correlation to One Password:

(100.0% in signature vs 06.74% overall) Module "libapple_nghttp2.dylib" = true
(100.0% in signature vs 06.94% overall) Module "QuickLookThumbnailing" = true
(100.0% in signature vs 06.94% overall) Module "MobileKeyBag" = true
(100.0% in signature vs 07.20% overall) Module "AppleFSCompression" = true
(100.0% in signature vs 07.24% overall) Module "CoreUtils" = true
(100.0% in signature vs 07.34% overall) Module "SpeechRecognitionCore" = true
(100.0% in signature vs 07.34% overall) Module "FSEvents" = true
(100.0% in signature vs 07.56% overall) Module "liblgpllibs.dylib" = true
(100.0% in signature vs 07.56% overall) Module "HIToolbox" = true
(100.0% in signature vs 07.56% overall) Module "Heimdal" = true
(100.0% in signature vs 07.56% overall) Module "libc++.1.dylib" = true
(100.0% in signature vs 07.56% overall) Module "Security" = true
(100.0% in signature vs 07.56% overall) Module "CarbonCore" = true
(100.0% in signature vs 07.56% overall) Module "RemoteViewServices" = true
(100.0% in signature vs 07.56% overall) platform = Mac OS X
(73.33% in signature vs 00.73% overall) Addon "onepassword4@agilebits.com" Version = 4.7.3.1 [84.62% vs 01.63% if startup_crash = 0]

I submitted them from my Mac machine but I also experienced crashes from my Linux machine.

Such as a014500d-d594-4c90-a79d-525c10190219

Let me know if I can be of any help!

(In reply to sommerquentin67 from comment #3)

I submitted them from my Mac machine but I also experienced crashes from my Linux machine.

Such as a014500d-d594-4c90-a79d-525c10190219

Let me know if I can be of any help!

Are you actively using Twitter in the browser that is crashing?

Yep, as well as 1password.

Also I'm indeed using their new interface.

(In reply to sommerquentin67 from comment #5)

Yep, as well as 1password.

Also I'm indeed using their new interface.

Can you provide an exact set of STR that generates the crash? This would be helpful.

Flags: needinfo?(sommerquentin67)
Summary: Firefox crash during normal use → Crash on @ poll
Component: Untriaged → Networking
Product: Firefox → Core

Sorry, I have honestly no idea how to reproduce this. I didn't even link it to Twitter before you mentioned it. I'll keep an eye out for the next occurrences but I'm not at all confident I will be able to provide steps to reproduce.

So I didn't manage to reproduce it but I witnessed it several times.

It seems to happen more on twitter.com when a media is playing (I've seen both GIF and video). It just happened while I was playing the media in this tweet: https://twitter.com/philsturgeon/status/1103317523519467520

As a reminder this happen in the new Twitter web UI (You can enable it from your account)

Flags: needinfo?(sommerquentin67)

Other example of media that just crashed: https://twitter.com/RothMathieu/status/1103320439504269312

The priority flag is not set for this bug.
:valentin, could you have a look please?

Flags: needinfo?(valentin.gosu)

This is most likely a dupe. Dragana, do you know the other bug number?

Flags: needinfo?(valentin.gosu) → needinfo?(dd.mozilla)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(dd.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1516325
You need to log in before you can comment on or make changes to this bug.