Closed Bug 1528760 Opened 2 years ago Closed 2 years ago

Set Desktop Background Preview Window is pretty broken on OSX

Categories

(Firefox :: Shell Integration, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- verified

People

(Reporter: johannh, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(2 files)

See screenshot, it has twice the same button and there's no preview.

This is WFM in 66 but fails in 67. Given the changes to get it working again, I think this is a regression from bug 1514594.

browser_1119088.js has the foundation for testing set in background on Mac, though I don't have time to see if I can make that work for the dialog this week, so I'll go with fixing the issue for now, and will file a follow-up for the test.

Assignee: nobody → standard8
Blocks: 1514594
Status: NEW → ASSIGNED
Keywords: regression

Oh, I forgot to say, in the browser console I'm seeing:

SyntaxError: redeclaration of var AppConstants setDesktopBackground.js:1:1
ReferenceError: gSetBackground is not defined setDesktopBackground.xul:1:1

The AppConstants issue is that we're trying to redefine it as a const, because we don't know that utilityOverlay.js (loaded via the xul) is already defining it. So we just have to drop the extra redeclaration and tell ESLint about it.

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1653389a43da
Fix issues in the setDesktopBackground dialog following the ChromeUtils.import global changes. r=johannh
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Flags: qe-verify+

I’ve reproduced this issue with Fx 67.0a1 (2019-02-18) on macOS 10.13.
The issues is verified fixed with Fx 67.0b11 on OS X (version 10.11 and 10.13).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.