[wpt-sync] Sync PR 15449 - [css-tables] Add some subpixel collapsed border tests

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P4
normal
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: wptsync, Unassigned)

Tracking

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [wptsync downstream], )

Sync web-platform-tests PR 15449 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/15449
Details from upstream follow.

David Grogan <dgrogan@chromium.org> wrote:

[css-tables] Add some subpixel collapsed border tests

This CL contains tests only, no behavior change.

Chrome passes 001.
Firefox passes 001 and 002.
Safari hidpi passes 001, 002, and 003.

Chrome probably passes 001 but fails 002 because of LayoutUnit's 1/64
pixel precision but that's not confirmed.

Note that these tests will become invalid if the proposal in
https://github.com/w3c/csswg-drafts/issues/606 is adopted.

Bug: 377847
Change-Id: Ifc9e8f9f878f7462cb949670350eadb17c7c2940

Reviewed-on: https://chromium-review.googlesource.com/1477334
WPT-Export-Revision: 189ddac775721a12964ebeaf486fb3a502cfed68

Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Ran 3 tests
PASS   : 2
FAIL   : 1

New tests that have failures or other problems:
/css/css-tables/subpixel-collapsed-borders-003.html: FAIL
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7d54ecab8dc1
[wpt PR 15449] - [css-tables] Add some subpixel collapsed border tests, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/71768e55e777
[wpt PR 15449] - Update wpt metadata, a=testonly
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3a39e45af185
[wpt PR 15449] - [css-tables] Add some subpixel collapsed border tests, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/aef3f8d081d1
[wpt PR 15449] - Update wpt metadata, a=testonly
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.