Closed Bug 15289 Opened 21 years ago Closed 21 years ago

Caret doesn't always shift right on <space>

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 14573

People

(Reporter: phil, Assigned: kinmoz)

Details

I brought up a mail compose window in HTML mode. When I type in the body of the
message, and type a single <space> the cursor doesn't shift right. Seems like if
I type several spaces, it moves right eventually.

The plain text edit fields in the addressing area don't seem to have this
problem.
Assignee: buster → kin
Target Milestone: M12
assigned to kin who is looking at simon's caret painting bugs, cc joe in case
there's some rules issue involved here
This only happens at the end of a line or block where there is nothing following
the space.

There seems to be some optimization in layout that does not extend the text
frame's width for a trailing space. This optimization seems to be turned off
when inside of a Pre block.

Cc'ing kipp@netscape.com and troy@netscape.com for confirmation on this.
Status: NEW → ASSIGNED
Accepting bug.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 14573 ***
Status: RESOLVED → VERIFIED
verified in 10/12 build
You need to log in before you can comment on or make changes to this bug.