Closed Bug 1529166 Opened 6 months ago Closed 5 months ago

Magnified website bug after exiting responsive design mode.

Categories

(DevTools :: Responsive Design Mode, defect)

65 Branch
Desktop
All
defect
Not set

Tracking

(firefox65 affected, firefox66 affected, firefox67 affected)

RESOLVED DUPLICATE of bug 1541158
Tracking Status
firefox65 --- affected
firefox66 --- affected
firefox67 --- affected

People

(Reporter: ong-xc, Assigned: bradwerth)

References

(Blocks 1 open bug)

Details

(Whiteboard: [dt-q])

Attachments

(1 file, 3 obsolete files)

Attached file List of evidence :D

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  1. Magnified a page to 300%
  2. Enter responsive design mode.
  3. Magnified to 100%
  4. Exit responsive design mode.

Actual results:

Page stays magnified at 300%.

Expected results:

Page should de-magnified back to 100%.

Tested this issue on several machines: Windows 10, Mac OS X - Firefox versions: latest nightly 67.0a1, beta 66.0b10, and release 65.0.1 and 65.0. On all versions the issue can be reproduced. Specially, try with the Reddit and Wikipedia websites.

Status: UNCONFIRMED → NEW
Component: Untriaged → Responsive Design Mode
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → DevTools
Hardware: Unspecified → Desktop

This seems to be related to bug 1516413, might be the same root issue but different steps to reproduce.

Blocks: rdm-zoom
Priority: -- → P2
See Also: → 1516413
Whiteboard: [dt-q]

I'll attempt to figure it out.

Assignee: nobody → bwerth

https://phabricator.services.mozilla.com/D23583 allows FullZoom messages to passthrough to the RDM document. The document reverts to the container zoom level when RDM is closed, but scrollbar layout is affected. Bug 1501665 will likely fix that, so blocking this bug on that landing.

Depends on: 1501665
Status: NEW → ASSIGNED
Priority: P2 → P1
Whiteboard: [dt-q] → [rdm-mvp] [dt-q]

Since the RDM UI is presented as UI, it makes sense for it to stay at
the same zoom level as the rest of the interface.

Depends on D23583

Depends on: 1541158

I'm breaking this bug into pieces since we know how to solve parts of the problem, but not yet all of the problem.

Depends on: 1541175
Attachment #9051110 - Attachment is obsolete: true
Attachment #9054246 - Attachment is obsolete: true
Attachment #9054248 - Attachment is obsolete: true

It looks like this will be resolved totally by the fixes for Bug 1541158.

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1541158
Priority: P1 → --
Whiteboard: [rdm-mvp] [dt-q] → [dt-q]
You need to log in before you can comment on or make changes to this bug.