Closed Bug 1529260 Opened 2 years ago Closed 8 months ago

Text snapping more noticeable after animation on https://git.news/

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox73 --- wontfix
firefox74 --- fixed
firefox75 --- fixed

People

(Reporter: jrmuizel, Assigned: aosmond)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Also notice a small amount of snapping in Safari but it's less noticeable than in Firefox.

Blocks: wr-snap
Blocks: wr-68
Priority: -- → P3

Lee, do you see what I'm talking about here? Can we do better?

Assignee: nobody → lsalzman
Blocks: wr-70
No longer blocks: wr-68
No longer blocks: wr-70
Flags: needinfo?(lsalzman)

Andrew, do your recent snapping changes help this any?

Flags: needinfo?(lsalzman) → needinfo?(aosmond)

This patch makes the CPU side incorporate the raster scale when
calculating the subpixel position of a glyph. It also makes the shader
side not include the glyph scale factor when recalculating the glyph
position (since it was not known/used when determining the subpixel
position in the first place). This makes the subpixel position stable
when we transition between Screen and Local(raster_scale) spaces.

Assignee: lsalzman → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(aosmond)
OS: Unspecified → All
Hardware: Unspecified → All
Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9bd4120bc977
Match shader and CPU glyph rasterization logic for glyphs in local space. r=lsalzman
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Duplicate of this bug: 1604241

Comment on attachment 9126544 [details]
Bug 1529260 - Match shader and CPU glyph rasterization logic for glyphs in local space.

Beta/Release Uplift Approval Request

  • User impact if declined: Glyphs may wiggle / be placed on the wrong subpixel position during animations
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It is a minor change to how to we place glyphs when animated with WebRender. It is already drawn at the wrong position, so it is unlikely to get worse.
  • String changes made/needed:
Attachment #9126544 - Flags: approval-mozilla-beta?

Comment on attachment 9126544 [details]
Bug 1529260 - Match shader and CPU glyph rasterization logic for glyphs in local space.

Fixes visual glitches related to glyph positioning with WebRender. Approved for 74.0b4.

Attachment #9126544 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.