Add web frame and web window types to web webdriver Rust crate

RESOLVED FIXED in Firefox 67

Status

enhancement
P1
normal
RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: ato, Assigned: nupurbaghel)

Tracking

(Blocks 2 bugs, {good-first-bug})

Version 3
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago

We are missing the web window and web frame types in the webdriver
crate.

Both the web window and the web frame behaves like the web element,
and they both have a string value associated with them. The new
types should be added in testing/webdriver/src/common.rs and mimick
the behaviour of the existing WebElement.

(Reporter)

Updated

2 months ago
Keywords: good-first-bug
(Reporter)

Updated

2 months ago
Depends on: 1529291
(Assignee)

Comment 1

2 months ago

Hi :ato,

I would like to take up this issue.
Since it already has a linked issue 1529291, should I start with the linked one instead?
Also, I have currently been able to cargo-build the geckodriver module. Does this task require me to build the complete Firefox package or only the webdriver module?

(Reporter)

Comment 2

2 months ago

It would probably be a good idea to fix
https://bugzilla.mozilla.org/show_bug.cgi?id=1529291 first, otherwise
you will end up having to make three changes (first add new
abstractions, then going back to change them into struct units).

Both bugs can be done with a regular build of geckodriver, either
using "cargo build" in testing/geckodriver or testing/webdriver,
or by "./mach build testing/geckodriver" in the top-level source
directory.

(Reporter)

Updated

2 months ago
Assignee: nobody → nupurbaghel
Status: NEW → ASSIGNED
Priority: -- → P1

Comment 4

2 months ago
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/654492de5212
Add web frame and web window types to web webdriver Rust crate. r=ato

Comment 5

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
(Reporter)

Updated

a month ago
Duplicate of this bug: 1470654
You need to log in before you can comment on or make changes to this bug.