Closed Bug 1529307 Opened 7 months ago Closed 6 months ago

Discovery stream does not clear store if pref changes to on

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1529035
Iteration:
68.2 - Apr 1 - 14
Tracking Status
firefox66 --- wontfix
firefox67 --- fix-optional

People

(Reporter: thecount, Assigned: thecount)

References

Details

Not a huge concern, because it's only an issue while manually changing your preff from an on state to another on state.

If we go from discovery stream off to discovery stream on via pref change, things work as expected. When it is enabled, we clear cache and fetch new data. This works fine because it was previously off and thus the store would by default b empty.

If we go from discovery stream on to discovery stream off, we clear cache and clear the store. Also works as expected.

If we're changing the pref from an on state to another on state (example, turn spocs on from off) We clear cache and fetch new data. The issue here is if Discovery Stream was already on, we already have something in state which also loads.

To test:

  1. Turn on discovery stream via setting browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","enabled":true,"show_spocs":false,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=$apiKey&layout_variant=basic"}
  2. Use a slow layout, dev-test-feeds probably works best.
  3. Open a new tab.

Expected: You should see nothing but search while it loads.
Actual: You see top sites while it loads. If the layout was a bit different, things might jump around the screen. This is because when it tries to render, it checks to see if we're able to load data, and even thought the feeds are still loading, the jsx sees old stuff in the cache thus tries to display an older layout.

Assignee: nobody → sdowne
Iteration: --- → 68.1 - Mar 18 - 31
Priority: -- → P2
Priority: P2 → P1
No longer blocks: 1512725
Iteration: 68.1 - Mar 18 - 31 → 68.2 - Apr 1 - 14
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1529035
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.