Closed Bug 1529319 Opened 3 years ago Closed 2 years ago

Cannot click on label next to radio input to select the radio input option

Categories

(Toolkit :: Preferences, defect, P3)

All
Unspecified
defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox71 --- verified

People

(Reporter: robwu, Assigned: Paolo)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

STR:

  1. Visit the new HTML-based about:config

  2. Type any non-existent pref e.g., non-existent-pref

  3. The following will be rendered:

    non-existent-pref     o Boolean o Number o String   [Add]
    
  4. Click on the "Number" text label.

Expected:

  • The radio input before "Number" should be selected.

Actual:

  • Nothing happens. To select the desired type I now need to aim my mouse pointer at the radio box and click there.

This is easy to fix, just create a <label> element, and append the input+span to that element instead of form, and then append that label to the form at https://searchfox.org/mozilla-central/rev/4587d146681b16ff9878a6fdcba53b04f76abe1d/browser/components/aboutconfig/content/aboutconfig.js#229,232

Priority: -- → P5

This just bit me... I actually clicked several times because I was so incredulous it didn't work. We shouldn't ship without fixing trivial stuff like this.

Priority: P5 → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576943

I'm reopening this bug because the solution described in comment 0 was the correct one, while the implementation in bug 1576943 uses an ID which breaks the case of multiple forms shown on the page. I'll write a patch to fix this.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #9089610 - Attachment description: Bug 1529319 - Fix clicking radio buttons in "about:config" with multiple forms displayed. r=jaws → Bug 1529319 - Part 2 - Test clicking radio buttons in "about:config" with multiple forms displayed. r=zbraniecki
Keywords: leave-open
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/autoland/rev/ef66bc33c166
Part 1 - Fix clicking radio buttons in "about:config" with multiple forms displayed. r=jaws
Keywords: leave-open
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/autoland/rev/ef645e35877a
Part 2 - Test clicking radio buttons in "about:config" with multiple forms displayed. r=zbraniecki
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → paolo.mozmail
Flags: qe-verify+

Confirmed issue with 67.0a1 (2019-02-26) on Widnows 10.
Verified fix with 71.0b5 on Windows 10, Ubuntu 18.04, 71.0b3 on macOS 10.14.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Hardware: Unspecified → All
You need to log in before you can comment on or make changes to this bug.