When re-sizing of colums, other columns get auto re-sized

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: s.kumar, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I had the fields Subject, Sender, Date, and Size displayed.  I set subject, and
sender to the size I wanted.  When I made the date field smaller, I was
intending to have more space for size.  Instead, it automatically extended
Subject to fit whatever space was being released by the reduction of the date
field.  

It is however, not consistent in it's behaviour.  It feels like there's a logic
to this, but it's not obvious, as I use it, what the logic is.  Looks like it
basically stops expanding the size field when it no longer needs any more space
to display the current list of mail being looked at.

Comment 1

15 years ago
s.kumar: Is this still an issue for you?  In 1.4b, the resizing of columns in 
the mail views seems to be very simple -- other than a few fixed-width fields 
(e.g. junk status), moving the boundary of a column only affects the adjacent 
column, which seems to be what you expect.

Comment 2

15 years ago
*** Bug 194950 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
=>WFM, no response from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
Yes, this bug looks resolved, but Bug 194950 does not look resolved, despite it
was marked as a duplicate.  

Comment 5

15 years ago
Okay, here is where it goes wrong.
1) Size the entire window to how big you want it to be.
2) Start from the left and fix each column to the proper width.
(The last column on the right will have extra space left over.)
3) Move the window divider to account for the extra space.
RESULT: Window resize undo's all the work you just put into your columns.

Also, double clicked should automatically set the column width to the optimal
width for the data being displayed, such as windows explorer does.  
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.