Windows WindowsDllBlocklist bustage when Gecko 67 merges to beta on 2019-03-11

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: stefan_hindli, Assigned: aklotz)

Tracking

unspecified
mozilla67
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

4 months ago

Central as Beta simulation:

https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&classifiedState=unclassified&author=shindli%40mozilla.com&selectedJob=229666328

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=229666328&repo=try&lineNumber=30219

Failure log snippet:

16:34:12 INFO - ^
16:34:12 INFO - 1 error generated.
16:34:12 INFO - z:/build/build/src/config/rules.mk:805: recipe for target 'WindowsDllBlocklist.obj' failed
16:34:12 INFO - mozmake.EXE[4]: *** [WindowsDllBlocklist.obj] Error 1
16:34:12 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/mozglue/build'
16:34:12 INFO - z:/build/build/src/config/recurse.mk:74: recipe for target 'mozglue/build/target' failed
16:34:12 INFO - mozmake.EXE[3]: *** [mozglue/build/target] Error 2
16:34:12 INFO - mozmake.EXE[3]: *** Waiting for unfinished jobs....
16:34:12 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/media/ffvpx/libavutil'
16:34:12 INFO - z:/build/build/src/vs2017_15.8.4/SDK/bin/10.0.17134.0/x64/rc.exe -nologo -r -DNDEBUG=1 -DTRIMMED=1 -D_USE_MATH_DEFINES -Dinline=__inline -DHAVE_AV_CONFIG_H -Iz:/build/build/src/media/ffvpx/libavutil -Iz:/build/build/src/obj-firefox/media/ffvpx/libavutil -Iz:/build/build/src/media/ffvpx -Iz:/build/build/src/media/ffvpx/compat/atomics/win32 -Iz:/build/build/src/obj-firefox/dist/include -Fomodule.res z:/build/build/src/obj-firefox/media/ffvpx/libavutil/module.rc
16:34:12 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/media/ffvpx/libavutil'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm'
16:34:13 INFO - security/nss/lib/softoken/legacydb/lgdestroy.obj
16:34:13 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang.exe --driver-mode=cl -Xclang -std=gnu99 -m32 -Folgdestroy.obj -c -DNDEBUG -DTRIMMED=1 '-DSHLIB_SUFFIX="dll"' '-DSHLIB_PREFIX=""' '-DLG_LIB_NAME="nssdbm3.dll"' -DNSS_FIPS_DISABLED -DNSS_NO_INIT_SUPPORT -DNSS_X86_OR_X64 -DNSS_X86 -DUSE_UTIL_DIRECTLY -DNO_NSPR_10_SUPPORT -DSSL_DISABLE_DEPRECATED_CIPHER_SUITE_NAMES -D_WINDOWS -DWIN95 -D_CRT_SECURE_NO_WARNINGS -D_CRT_NONSTDC_NO_WARNINGS -DNSS_DISABLE_LIBPKIX -DWIN32 -Iz:/build/build/src/security/nss/lib/softoken/legacydb -Iz:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/private/nss -Iz:/build/build/src/obj-firefox/dist/include/dbm -Iz:/build/build/src/obj-firefox/dist/include/nss -Iz:/build/build/src/obj-firefox/dist/include -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -guard:cf -fcrash-diagnostics-dir=z:/build/public/build -nologo -wd4091 -D_HAS_EXCEPTIONS=0 -guard:cf -W3 -Gy -Zc:inline -arch:SSE2 -Gw -wd4244 -wd4267 -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -we4553 -Z7 -Xclang -load -Xclang z:/build/build/src/obj-firefox/build/clang-plugin/clang-plugin.dll -Xclang -add-plugin -Xclang moz-check -O2 -Oy- -Qunused-arguments -Xclang -MP -Xclang -dependency-file -Xclang .deps/lgdestroy.obj.pp -Xclang -MT -Xclang lgdestroy.obj z:/build/build/src/security/nss/lib/softoken/legacydb/lgdestroy.c
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'
16:34:13 INFO - toolkit/mozapps/update/updater/updater.obj
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm'
16:34:13 INFO - security/nss/lib/softoken/legacydb/lgfind.obj
16:34:13 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang.exe --driver-mode=cl -Xclang -std=gnu99 -m32 -Folgfind.obj -c -DNDEBUG -DTRIMMED=1 '-DSHLIB_SUFFIX="dll"' '-DSHLIB_PREFIX=""' '-DLG_LIB_NAME="nssdbm3.dll"' -DNSS_FIPS_DISABLED -DNSS_NO_INIT_SUPPORT -DNSS_X86_OR_X64 -DNSS_X86 -DUSE_UTIL_DIRECTLY -DNO_NSPR_10_SUPPORT -DSSL_DISABLE_DEPRECATED_CIPHER_SUITE_NAMES -D_WINDOWS -DWIN95 -D_CRT_SECURE_NO_WARNINGS -D_CRT_NONSTDC_NO_WARNINGS -DNSS_DISABLE_LIBPKIX -DWIN32 -Iz:/build/build/src/security/nss/lib/softoken/legacydb -Iz:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/private/nss -Iz:/build/build/src/obj-firefox/dist/include/dbm -Iz:/build/build/src/obj-firefox/dist/include/nss -Iz:/build/build/src/obj-firefox/dist/include -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -guard:cf -fcrash-diagnostics-dir=z:/build/public/build -nologo -wd4091 -D_HAS_EXCEPTIONS=0 -guard:cf -W3 -Gy -Zc:inline -arch:SSE2 -Gw -wd4244 -wd4267 -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -we4553 -Z7 -Xclang -load -Xclang z:/build/build/src/obj-firefox/build/clang-plugin/clang-plugin.dll -Xclang -add-plugin -Xclang moz-check -O2 -Oy- -Qunused-arguments -Xclang -MP -Xclang -dependency-file -Xclang .deps/lgfind.obj.pp -Xclang -MT -Xclang lgfind.obj z:/build/build/src/security/nss/lib/softoken/legacydb/lgfind.c
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'
16:34:13 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang.exe --driver-mode=cl -m32 -Foarchivereader.obj -c -DNDEBUG=1 -DTRIMMED=1 -DUNICODE -D_UNICODE -DNS_NO_XPCOM '-DMAR_CHANNEL_ID="firefox-mozilla-beta"' '-DMOZ_APP_VERSION="67.0"' -Iz:/build/build/src/toolkit/mozapps/update/updater -Iz:/build/build/src/obj-firefox/toolkit/mozapps/update/updater -Iz:/build/build/src/toolkit/xre -Iz:/build/build/src/toolkit/mozapps/update/common -Iz:/build/build/src/xpcom/base -Iz:/build/build/src/obj-firefox/dist/include -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/nss -MT -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -guard:cf -Qunused-arguments -fcrash-diagnostics-dir=z:/build/public/build -TP -nologo -w15038 -wd5026 -wd5027 -Zc:sizedDealloc- -wd4091 -wd4577 -D_HAS_EXCEPTIONS=0 -guard:cf -W3 -Gy -Zc:inline -arch:SSE2 -Gw -wd4251 -wd4244 -wd4267 -wd4800 -wd4595 -wd4065 -Wno-inline-new-delete -Wno-invalid-offsetof -Wno-microsoft-enum-value -Wno-microsoft-include -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Wno-inconsistent-missing-override -Wno-implicit-exception-spec-mismatch -Wno-unused-local-typedef -Wno-ignored-attributes -Wno-used-but-marked-unused -we4553 -D_SILENCE_TR1_NAMESPACE_DEPRECATION_WARNING -GR- -Z7 -Xclang -load -Xclang z:/build/build/src/obj-firefox/build/clang-plugin/clang-plugin.dll -Xclang -add-plugin -Xclang moz-check -O2 -Oy- -WX -Xclang -MP -Xclang -dependency-file -Xclang .deps/archivereader.obj.pp -Xclang -MT -Xclang archivereader.obj z:/build/build/src/toolkit/mozapps/update/updater/archivereader.cpp
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm'
16:34:13 INFO - security/nss/lib/softoken/legacydb/lgfips.obj
16:34:13 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang.exe --driver-mode=cl -Xclang -std=gnu99 -m32 -Folgfips.obj -c -DNDEBUG -DTRIMMED=1 '-DSHLIB_SUFFIX="dll"' '-DSHLIB_PREFIX=""' '-DLG_LIB_NAME="nssdbm3.dll"' -DNSS_FIPS_DISABLED -DNSS_NO_INIT_SUPPORT -DNSS_X86_OR_X64 -DNSS_X86 -DUSE_UTIL_DIRECTLY -DNO_NSPR_10_SUPPORT -DSSL_DISABLE_DEPRECATED_CIPHER_SUITE_NAMES -D_WINDOWS -DWIN95 -D_CRT_SECURE_NO_WARNINGS -D_CRT_NONSTDC_NO_WARNINGS -DNSS_DISABLE_LIBPKIX -DWIN32 -Iz:/build/build/src/security/nss/lib/softoken/legacydb -Iz:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/private/nss -Iz:/build/build/src/obj-firefox/dist/include/dbm -Iz:/build/build/src/obj-firefox/dist/include/nss -Iz:/build/build/src/obj-firefox/dist/include -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -guard:cf -fcrash-diagnostics-dir=z:/build/public/build -nologo -wd4091 -D_HAS_EXCEPTIONS=0 -guard:cf -W3 -Gy -Zc:inline -arch:SSE2 -Gw -wd4244 -wd4267 -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -we4553 -Z7 -Xclang -load -Xclang z:/build/build/src/obj-firefox/build/clang-plugin/clang-plugin.dll -Xclang -add-plugin -Xclang moz-check -O2 -Oy- -Qunused-arguments -Xclang -MP -Xclang -dependency-file -Xclang .deps/lgfips.obj.pp -Xclang -MT -Xclang lgfips.obj z:/build/build/src/security/nss/lib/softoken/legacydb/lgfips.c
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/security/nss/lib/softoken/legacydb/legacydb_nssdbm'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/mfbt/tests'
16:34:13 INFO - z:/build/build/src/obj-firefox/_virtualenvs/init/Scripts/python.exe z:/build/build/src/config/nsinstall.py -R -m 644 'TestFloatingPoint.exe' '../../dist/cppunittests'
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/mfbt/tests'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'
16:34:13 INFO - toolkit/mozapps/update/updater/module.res
16:34:13 INFO - Creating Resource file: module.res
16:34:13 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'
16:34:13 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/toolkit/mozapps/update/updater'

:aklotz could this be caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1528651 ? Can you please take a look?

Flags: needinfo?(aklotz)
Summary: Windows 2012 addon opt build in mozmake.EXE when Gecko 67 merges to beta on 2019-03-11 → Windows WindowsDllBlocklist bustage when Gecko 67 merges to beta on 2019-03-11
Assignee

Comment 1

4 months ago

Yes, this is unintended fallout from bug 1528651. I'll fix it.

Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Component: General → mozglue
Flags: needinfo?(aklotz)
OS: Unspecified → Windows
Priority: -- → P1
Product: Firefox Build System → Core

Comment 3

4 months ago
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ab8d4f3c348
Fix a straggling unused variable warning; r=dmajor

Comment 4

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.