Change all "Saved Logins" entry points to open Lockbox instead of toolkit management interface, when installed

VERIFIED FIXED in Firefox 67

Status

()

enhancement
P2
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: MattN, Assigned: MattN)

Tracking

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox67 verified)

Details

(Whiteboard: [passwords:lockbox-support])

Attachments

(2 attachments)

If the Lockbox webextension is installed, all the Saved Logins entry points should open Lockbox's login list instead of passwordManager.xul.

This should just be a matter of having LoginHelper.openPasswordManager check for the existence of Lockbox and that it is enabled and then opening its UI.

The preferences code will need special treatment since it uses a subdialog. The logic for detecting Lockbox being enabled can be added to LoginHelper then the prefs code can also use that to determine whether it should open Lockbox or load the subdialog.

The add-on ID is currently lockbox@mozilla.com.

The main question is whether we should open Lockbox in a tab (easy if we have a static URL) or open the doorhanger on that tab (we would need a way to tell Lockbox to open the panel for the tab). Needinfo to m_and_m for that.

Flags: qe-verify+
Flags: needinfo?(linuxwolf)

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #0)

The main question is whether we should open Lockbox in a tab (easy if we have a static URL) or open the doorhanger on that tab (we would need a way to tell Lockbox to open the panel for the tab). Needinfo to m_and_m for that.

The entry points should open Lockbox in a tab. We will need to work out how the Lockbox management URL is configured or determined; naively it seems feasible that Lockbox set a pref or property on install.

Flags: needinfo?(linuxwolf)

(In reply to Matthew Miller [:m_and_m] from comment #1)

(In reply to Matthew N. [:MattN] (PM me if requests are blocking you) from comment #0)

The main question is whether we should open Lockbox in a tab (easy if we have a static URL) or open the doorhanger on that tab (we would need a way to tell Lockbox to open the panel for the tab). Needinfo to m_and_m for that.

The entry points should open Lockbox in a tab. We will need to work out how the Lockbox management URL is configured or determined;

OK, as long as we have a URL (pattern) to use then that's easy. When that's decided it'd be great if you update this bug.

naively it seems feasible that Lockbox set a pref or property on install.

I don't even think we need that since we can check with the add-on manager to see if the extension is installed and enabled. That way we never have to worry about cleaning up after the extension. We're not in hot code paths so I don't think the performance of that lookup is a big deal.

In today's meeting we decided to just open a bare about:logins for now and we can always change it or add query parameters later.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED

If signon.management.overrideURI is set, open that URI in a new tab instead of opening passwordManager.xul in a window.

If signon.management.overrideURI is set, open that URI in a new tab instead of opening the preferences subdialog.

Depends on D23204

Try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=3c3b9d4a4f7471e73422daa3583ed5ee4e490c9c

This is a low-risk change as the new code is not executed unless the new preference is set (which won't be the case for any users for many months).

Comment 7

4 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/30dfd6603f79
Change Saved Logins menu items to open a pref-controlled URI, if set. r=jaws
https://hg.mozilla.org/integration/autoland/rev/e4a6f915841a
Honour signon.management.overrideURI for the Saved Logins prefs UI. r=jaws

Comment 8

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Comment 9

3 months ago

Hi Matthew, I'm having trouble installing the LockBox Web Extension, I tried downloading it from Github: https://github.com/mozilla-lockbox/lockbox-addon but when I try to install it I'm getting that it's corrupted, I'm not sure where or if I should modify some of the archived files myself, can you please provide the correct Add-on and maybe some Steps on how to Reproduce this issue and Verify it ?

Flags: needinfo?(MattN+bmo)

The Lockbox extension doesn't take advantage of this new preference yet so you will just have to test by manually setting the hidden preference signon.management.overrideURI to a URL that should open when "Saved Logins" is accessed from any of the entry points: context menu from a username/password field, autocomplete footer when you pref signon.showAutoCompleteFooter on, and the Saved Logins button at about:preferences#privacy.

Example:
A) set the signon.management.overrideURI hidden preference to "chrome://passwordmgr/content/passwordManager.xul" and you'll get a full-tab view of passwordManager.xul instead of a (sub)dialog (though it would never get pre-filtered for the hostname you're on like the dialog does).

B) set the signon.management.overrideURI hidden preference to "https://httpbin.org/get?filter=%DOMAIN%" and then you'll see the domain name of the page you opened the UI from (or "" from prefs) in the output:

{
  "args": {
    "filter": "example.com"
  }, 
  …
}
Flags: needinfo?(MattN+bmo)

Comment 11

3 months ago

Thanks for the extra steps, I can confirm this issue Verified as fixed in Firefox Nightly 67.0a1 (2019-03-17) using the steps from Comment 10

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.