Closed Bug 1529897 Opened 8 months ago Closed 8 months ago

"Default" theme should not switch to dark theme when GTK theme is dark

Categories

(Firefox :: Theme, defect, P1)

67 Branch
Unspecified
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- verified

People

(Reporter: good.martynov, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Go to "Customize" module. Compare "Default" and "Dark" themes either by hovering or selecting one after another.

Actual results:

Nothing happens. "Default" theme has become same as "Dark" one.

Expected results:

"Default" theme colors should be active.

FF Nightly version 67.0a1 (2019-02-22) (64-bit)

there's a similar report by another linux user with the default theme at https://old.reddit.com/r/firefox/comments/atfx4g/adaptive_theming_seems_broken_since_last_night/

Blocks: 1504766
Component: Untriaged → Theme
Keywords: regression
OS: Unspecified → Linux
Duplicate of this bug: 1529940

More likely a regression of bug 1525775

Blocks: 1525775
No longer blocks: 1504766
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "Default" theme not working → "Default" theme should not switch to dark theme when GTK theme is dark
Priority: -- → P2
See Also: → 1529323
Assignee: nobody → dao+bmo
Priority: P2 → P1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aebfdeb5bad6
Don't switch to the Dark theme when GTK theme is dark. r=Gijs
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Flags: qe-verify+

I've just updated to version 67.0a1 (2019-02-25) (64-bit) and do confirm that Default team appearance is back.

Kind thanks and appreciation for such a quick fix.

Whiteboard: [qa-triaged]
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]

Hi,

I've reproduced the above issue on Ubuntu 18.04 x64 on Nightly 67.0a1 20190222163114 using Adapta-Nokoto theme.

After the upgrade to the latest 68.0a1 20190320112939 the issue is not reproducible, using the same GTK Theme as before.

Based on above and Comment 8, marking as Verified.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.