If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Gecko uses more cpu with multiple windows open with flash embeds

VERIFIED FIXED in mozilla1.0.1

Status

()

Core
Plug-ins
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: kill this account, Assigned: kill this account)

Tracking

({topembed+})

Trunk
mozilla1.0.1
x86
Windows XP
topembed+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 RTM], URL)

Attachments

(13 attachments, 1 obsolete attachment)

114.57 KB, application/octet-stream
Details
98.99 KB, image/png
Details
113.61 KB, image/png
Details
78.76 KB, image/png
Details
22.38 KB, application/octet-stream
Details
124.22 KB, application/octet-stream
Details
32.97 KB, application/octet-stream
Details
117.08 KB, image/png
Details
141.63 KB, image/png
Details
116.72 KB, image/png
Details
106.97 KB, image/png
Details
113.31 KB, image/png
Details
112.99 KB, image/png
Details
(Assignee)

Description

16 years ago
The CPU usage on www.sina.com.cn is higher for gecko than IE.
Bug 152731 also deals with this issue but includes several other sites. 
The intent of this bug is to focus in on just one site.
(Assignee)

Comment 1

16 years ago
My system is a

 Dell Presision 210
 500MHz PIII
 384M ram
 running WinXP
(Assignee)

Comment 2

16 years ago
Created attachment 88399 [details]
zip of www.sina.com.cn and associated files saved via IE

This is a copy of the site so the testing can be reproduced on different
browsers
(Assignee)

Comment 3

16 years ago
Created attachment 88400 [details]
screen shot showing IE and taskmgr

IE uses about 75-80% CPU
(Assignee)

Comment 4

16 years ago
Created attachment 88401 [details]
screen shot showing NS 20020619 branch and taskmgr

NS 20020619 branch uses about 40% CPU
(Assignee)

Comment 5

16 years ago
Created attachment 88402 [details]
screen shot showing NS 20020619 trunk and taskmgr

NS 20020619 trunk uses about 50% CPU

Comment 6

16 years ago
how many cpu usage bugs are we going to file? :(  
 

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 152731 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
v
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

16 years ago
shrirang: please do not close this again. This is not a duplicate of bug 152731.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

16 years ago
shrirang: This issue is a high priority issue for some of us. It would not
surprise me if several bugs were opened. Bug 152732 is very defocused. Even a 
quick read thru bug 152731 indicates there may be different problems on different
sites as well as different problems on a given site. Bug 152731 does not have a
clearly identified problem.

As noted in the opening comments this bug is focused on just one site. This bug
may in fact break into several bugs if different problems are identified.
(Assignee)

Comment 11

16 years ago
s/Bug 152732/Bug 152731/

Comment 12

16 years ago
ok :)
(Assignee)

Comment 13

16 years ago
Created attachment 88492 [details]
zip of www.sina.com.cn and associated files

add <base href="">
disabled time_log accesses to www.sina.com.cn
(Assignee)

Updated

16 years ago
Attachment #88399 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #88399 - Attachment is obsolete: false
(Assignee)

Updated

16 years ago
Attachment #88492 - Attachment is obsolete: true
(Assignee)

Comment 14

16 years ago
branch build: 2002-06-19-08-1.0   - Shockwave Flash 6.0 r29
trunk build:  2002-06-19-08-trunk - Shockwave Flash 6.0 r29
IE                                - Flash 5
(Assignee)

Updated

16 years ago
Attachment #88399 - Attachment description: zip of www.sina.com.cn and associated files → zip of www.sina.com.cn and associated files saved via IE
(Assignee)

Comment 15

16 years ago
Created attachment 88533 [details]
zip of www.sina.com.cn and associated files saved via NS - part 1
(Assignee)

Comment 16

16 years ago
Created attachment 88534 [details]
zip of www.sina.com.cn and associated files saved via NS - part 2
(Assignee)

Comment 17

16 years ago
Created attachment 88535 [details]
zip of www.sina.com.cn and associated files saved via NS - part 3
(Assignee)

Comment 18

16 years ago
Created attachment 88538 [details]
screen shot showing IE and taskmgr (NS)

IE uses about 85%
(site saved via NS)
(Assignee)

Comment 19

16 years ago
Created attachment 88539 [details]
screen shot showing NS 20020619 trunk and taskmgr (NS)

NS trunk uses about 55%
(site saved via NS)

Comment 20

16 years ago
Flash bug? Is this reproducable with Flash 5 with Gecko? Is this reproducable
without Flash at all?

Comment 21

16 years ago
I tested this on NT with 0617 branch buidl with flash 5.0r41 and flash6.0r29 
(that  is bundled)


results:

* With flash 5.x, the cpu usage hovers between 35-90 %...mostly in the 60-80 
range sometime peaking to 90-95...

* With flash6.0r29 , the cpu usage dramatically goes up, and memory usage as 
well. The cpu range is like 55-100 %...mostly hovering in the low 90's...going 
to 100 often..

Flash bug ??????

Comment 22

16 years ago
bstell, can u try replacig the flash6 with flash5 on ur branch build and check? 
Thx!

Comment 23

16 years ago
dup of http://bugzilla.mozilla.org/show_bug.cgi?id=132759
(Assignee)

Comment 24

16 years ago
Created attachment 88578 [details]
screenshot of branch and taskmgr - Flash 5 r41
(Assignee)

Comment 25

16 years ago
NS branch uses about 21% with Flash 5
(Assignee)

Comment 26

16 years ago
Created attachment 88579 [details]
screenshot of IE and taskmgr (for comparison to previous attachment)

This was done just after the previous attachment.
IE using Flash 6 uses about 85% CPU to display http://www.sina.com.cn
(Assignee)

Comment 27

16 years ago
Created attachment 88666 [details]
screen shot showing NS 7.0 PR1and taskmgr

NS 7.0 PR1 uses about 45% to display http://www.sina.com.cn
(Assignee)

Comment 28

16 years ago
Created attachment 88670 [details]
screen shot showing NS 20020619 trunk (no flash) and taskmgr

without flash NS 20020619 trunk uses about 2% CPU to display
http://www.sina.com.cn

Comment 29

16 years ago
flash audio  test :

http://jazz/users/shrir/publish/flashacceptancesuite/Sound/Streaming/Kidrock.swf
(Assignee)

Comment 30

16 years ago
Switching to Flash 5 "solves" this issue so this is a dup of bug 132759.

*** This bug has been marked as a duplicate of 132759 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 31

16 years ago
.
Status: RESOLVED → VERIFIED

Comment 32

15 years ago
just talked with Brian. Am reopening this bug since it's a bit different than 
132759. Here, in this bug, we want to follow up on why flash eats up cpu even 
when 4 out of 5 windows are in the background. There is a significant more usage 
of cpu. We need macromedia's help on this..correct? For testing, pls check out 
Brian's comment in this bug here 
http://bugzilla.mozilla.org/show_bug.cgi?id=152731#c29

Open these tests one by one in seperate windows, then observe how much cpu gecko 
uses. You will be forced to kill netscape.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Summary: Gecko uses more CPU on www.sina.com.cn than IE → Gecko uses more cpu with multiple windows open with flash embeds
(Assignee)

Comment 33

15 years ago
try opening several separate windows showing http://www.macromedia.com/

The window bar and menus stop responding but interestingly buttons (eg: the 
netscape home page button) still respond.
can you say topembed :)
Keywords: topembed
(Assignee)

Comment 35

15 years ago
I opened bug 154725 to address the fact that the window bar and menus stop 
responding.

Updated

15 years ago
Blocks: 154896
Keywords: nsbeta1
Whiteboard: [adt2 RTM]
Target Milestone: --- → mozilla1.0.1

Updated

15 years ago
No longer blocks: 154896

Updated

15 years ago
Blocks: 154896

Comment 36

15 years ago
I couldn't understand: is this bug for moziila being slow on a pages with many
flash banners?

Moz is very slow and unresponsible if open a few pages on http://www.ixbt.com/.
(Assignee)

Comment 37

15 years ago
The issue is that Flash can use a large amount of CPU even if the Flash
is hidden. MacroMedia has a fix for this which should come out shortly.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 38

15 years ago
The issue of Flash using a significant amount of CPU even if it is not visible has
been fixed with the release of Flash r47.

Comment 39

15 years ago
shrir: can you pls verify this one as fixed? thanks!
Keywords: nsbeta1, topembed → nsbeta1+, topembed+

Comment 40

15 years ago
yeah, this issue was gone after we got new bits from macromedia.(6.0r47)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.