Closed Bug 1530011 Opened 1 year ago Closed 1 year ago

Assertion failure: eventStack.empty() in TraceLogging.cpp:875

Categories

(Core :: JavaScript Engine, defect, P2)

62 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: gregtatum, Assigned: denispal)

Details

Attachments

(1 file)

I keep on hitting this while running the profiler in debug build. I'm not sure on the exact STR, but I'm doing a bunch of capturing of profiles of cnn.com. It might be when I stop the profiler. If I get a more precise STR I will update.

STR:

  • Use a debug build.
  • Install Gecko Profiler Addon
  • Record a profile
  • Go to cnn.com
  • Capture profile
  • Stop profile

I'm not 100% sure where in that STR it's happening.

Assertion failure: eventStack.empty(), at /Users/gregorytatum/dev/gecko/js/src/vm/TraceLogging.cpp:875
Exiting due to channel error.

Permalink

Oh, and this is happening when the Tracelogger feature is turned off, and as far as I can tell ac_add_options --enable-trace-logging is disabled in my build config.

ni :dpalmeiro to get it on your radar.

Flags: needinfo?(dpalmeiro)

Ok, just reproduced, and it's:

STR:

  • Use a debug build.
  • Install Gecko Profiler Addon
  • Start recording ctrl + shift + 1
  • Load cnn.com
  • Capture profile ctrl + shift + 2

Then it hit the assertion

Thanks, I'll take a look. The trace logger is enabled by default in debug builds.

Assignee: nobody → dpalmeiro
Flags: needinfo?(dpalmeiro)
Priority: -- → P1
Priority: P1 → P2

This occurs while calculating durations whenever we reach the end of the event list and we didn't encounter the TraceLogger_Stop events for events that were still active when the profiler stopped.

An assert occurs while calculating durations whenever we reach the end of the event list and we didn't encounter the TraceLogger_Stop events for events that were still active when the profiler stopped. The fix is to use the last event as the end event for any remaining events on the stack.

Keywords: checkin-needed

Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/244b0ee2c890
When calculating event durations, if we reach the end of the event list then use the last event as the end event for any events that remain on the stack r=sfink

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.