Closed Bug 1530027 Opened 2 years ago Closed 2 years ago

Investigate changing the data: icons from the .xml files to separate files

Categories

(Firefox :: Search, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1496075

People

(Reporter: Felipe, Unassigned)

Details

(Whiteboard: [fxperf])

We should investigate if changing the search engine icons embedded as data: urls directly in the .xml files is worth it. (e.g.: converting from [1] to [2]). Some, but not all engines, are already like this.

The theoretical advantages are:

  • Search service initialization can be faster because the .xml files will be smaller
  • Image data won't be loaded for engines that are not used
  • Less data to send to the content process when it needs it (just a resource:// path and not the full data string-fied)

Mkaply said that there are plans to move these engines to webextensions, so I wonder how these two tasks would interact. The benefits of this also depends on how effective bug 1529380, bug 1529969 and bug 1529979 will be, and if the handoff-to-awesomebar feature of about:newtab will stick.

The effort looks really simple at the moment, but we need to make sure the improvement is not negligible.

[1] https://searchfox.org/mozilla-central/rev/dc0adc07db3df9431a0876156f50c65d580010cb/browser/components/search/searchplugins/bing.xml#9
[2] https://searchfox.org/mozilla-central/source/browser/components/search/searchplugins/google.xml#9

Dale, can you tell me a little bit about the work going on to move these to webextensions?

Flags: needinfo?(dharvey)

The bug to in https://bugzilla.mozilla.org/show_bug.cgi?id=1496075 + https://bugzilla.mozilla.org/show_bug.cgi?id=1486820

Web extensions require their icons to be local files inside the extension so there will be no icons in data uris once this patch lands

Flags: needinfo?(dharvey)

Ah great, thanks. I see that the patches in bug 1496075 are doing this, so I'll mark this as a duplicate

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1496075
You need to log in before you can comment on or make changes to this bug.