Firefox slow resolving any host for the first time, then it's fine (due to IPv6 enabled)

RESOLVED DUPLICATE of bug 1122907

Status

()

defect
RESOLVED DUPLICATE of bug 1122907
5 months ago
4 months ago

People

(Reporter: sam.xubuntu, Unassigned)

Tracking

67 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/71.0.3578.98 Chrome/71.0.3578.98 Safari/537.36

Steps to reproduce:

Affected OSes:
Ubuntu/Xubuntu 18.04.1/18.04.2 LTS

Non-affected OSes:
Windows 10

Browser:
Firefox latest stable version and previous versions at least back to when Ubuntu 18.04.1 was out.

Machines:
Intel Core i5, desktop PC, either using a GPU card or the integrated one
Asus X553M, notebook

Problem:
Firefox is very slow when loading a given host for the first time, e.g. www.google.com or www.youtube.com
After it's done loading, browsing on that domain is ok.
Please watch the video (it's on vimeo.com) since it's the best way to understand the problem.
https://vimeo.com/319319274
Some text and web pages content are in italian because of the geolocalization.
In the video I use VirtualBox for recording convenience but it's the same behaviour in the host machine.

Tried:
Everything (Ubuntu clean install, reset Firefox profile, proxy settings, disable hardware acceleration, disabling/removing all plugins and extensions, connect to cable - no router).

Important:
Chromium and Opera work fine on the same machine-OS combinations.

Actual results:

Expected results:

Component: Untriaged → Networking: DNS
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
Summary: Firefox in Ubuntu is slow resolving any host for the first time, then it's fine → Firefox slow resolving any host for the first time, then it's fine (due to IPv6 enabled)

Why this is invalid?
network.dns.disableIPv6 is false in default. It means IPv6 DNS is enabled by default.
So, Firefox should fix this bug OR should change default value. no?

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

(In reply to Alice0775 White from comment #2)

So, Firefox should fix this bug OR should change default value. no?

Yes, indeed. However it's important to notice that:

  • In Windows network.dns.disableIPv6 is ALSO set to false, however it works fine on the same machines.

This means that the bug affects Ubuntu + Firefox systems only (or any GNU/Linux + Firefox).

However, there would be thousands/millions of users reporting this problem, so my guess is that the combination that causes the bug is something like:

  • Ubuntu + Firefox + Some providers (ISP) that currently have some problems with IPv6?

I'm available for further testing/questions.

Hello Reporter:
Can you please provide HTTP log if you can reproduce? See https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

Flags: needinfo?(sam.xubuntu)
Posted file Network log

(In reply to Junior [:junior] from comment #4)

Hello Reporter:
Can you please provide HTTP log if you can reproduce? See https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

Sure.
What I did:

  • network.dns.disableIPv6 set to false (default value) and no addons
  • Start logging
  • Immediately click bookmark of https://www.google.com
  • Took ~30 seconds to completely load
  • When finished loading, waited a few seconds
  • Stop logging

Log file attached to OP.

Flags: needinfo?(sam.xubuntu)

Thanks for providing the log.

By log, it takes 5 secs to resolve www.google.com, which is the default timeout. Please see bug 1122907 Comment 17 for a workaround.

Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122907

(In reply to Junior [:junior] from comment #6)

Please see bug 1122907 Comment 17 for a workaround.

Thanks. Yes I already knew about the workaround as I wrote in my previous post: comment 1

So this is a 4 years old bug?
I'm curious though, why doesn't it happen on Windows?

I'm curious though, why doesn't it happen on Windows?

Actually firefox doesn't do DNS resolution.
We delegate to OS.
Hence the OS (and other routing/config) behavior matters.

It's worth noting though that Chrome has IPv6 enabled too but it does work on Linux on the same machine.
So I guess it can still be considered a Firefox bug.

For what it worth, we have trr which is default off now.
Trr is not relying on OS.

You may want to have a try to set network.trr.mode to 1 in about:config

You need to log in before you can comment on or make changes to this bug.