Closed Bug 1530393 Opened 11 months ago Closed 11 months ago

WebRender crashes on assert with out-of-process iframes

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1527380

People

(Reporter: hsivonen, Unassigned)

Details

Steps to reproduce (I used self-built debug build without local patches on Linux x86_64, XWayland):

  1. Set gfx.webrender.all to true
  2. Set browser.fission.oopif.attribute to true
  3. Navigate to https://hsivonen.fi/fission-host.html

Actual results:
Crash on assertion:
Hit MOZ_CRASH(assertion failed: frame_state.tile_cache.is_none()) at gfx/wr/webrender/src/prim_store/mod.rs:1742

Additional info:
Attaching gdb fails to catch the process in the right state, so no backtrace that way. The problem doesn't repro in rr, so no backtrace that way, either. (The backtrace printed by Gecko itself has only libxul offsets.)

I think this is a dupe of bug 1527380. For now you can set gfx.webrender.picture-caching to false.

Thanks.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1527380
Component: Graphics: WebRender → Graphics
You need to log in before you can comment on or make changes to this bug.