Open Bug 1530566 Opened 2 years ago Updated 17 days ago

Intermittent toolkit/components/passwordmgr/test/browser/<anything> | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run -

Categories

(Toolkit :: Password Manager, defect, P3)

defect

Tracking

()

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [stockwell disabled])

Attachments

(1 file)

#[markdown(off)]
Filed by: nerli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=230448207&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/Jlql49OOSja919a9LYlLPQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-02-26T01:20:38.119Z] 01:20:38 INFO - TEST-START | toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js
[task 2019-02-26T01:20:38.200Z] 01:20:38 INFO - GECKO(11629) | MEMORY STAT | vsize 2074MB | residentFast 342MB | heapAllocated 123MB
[task 2019-02-26T01:20:38.201Z] 01:20:38 INFO - TEST-OK | toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js | took 87ms
[task 2019-02-26T01:20:38.223Z] 01:20:38 INFO - checking window state
[task 2019-02-26T01:20:38.225Z] 01:20:38 INFO - TEST-INFO | started process screentopng
[task 2019-02-26T01:20:38.768Z] 01:20:38 INFO - TEST-INFO | screentopng: exit 0
[task 2019-02-26T01:20:38.768Z] 01:20:38 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run -

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → INCOMPLETE

There are 33 failures associated to this bug in the last 7 days. These are occurring on macosx1014-64 debug builds.

:MattN can you take a look?

Flags: needinfo?(MattN+bmo)
Whiteboard: [stockwell needswork:owner]

Hi Geoff, seems like this is one of those tests that just won't give up https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-06-13&endday=2019-10-11&tree=trunk&bug=1530566

Since the triage owner did not reply, do we disable it?

There are 24 total failures in the last 7 days on macosx1014-64 debug.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=270796986&repo=autoland&lineNumber=23840

[task 2019-10-10T23:37:00.643Z] 23:37:00 INFO - TEST-START | toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js
[task 2019-10-10T23:37:00.720Z] 23:37:00 INFO - GECKO(1965) | ++DOCSHELL 0x10a63c000 == 2 [pid = 1969] [id = {9200e863-ba72-7246-9b49-c41b68f7eca4}]
[task 2019-10-10T23:37:00.721Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 13 (0x11c34a7a0) [pid = 1969] [serial = 169] [outer = 0x0]
[task 2019-10-10T23:37:00.721Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 14 (0x11c3a3000) [pid = 1969] [serial = 170] [outer = 0x11c34a7a0]
[task 2019-10-10T23:37:00.756Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 15 (0x11e1dfc00) [pid = 1969] [serial = 171] [outer = 0x11c34a7a0]
[task 2019-10-10T23:37:00.856Z] 23:37:00 INFO - GECKO(1965) | --DOMWINDOW == 2 (0x140d27400) [pid = 1977] [serial = 102] [outer = 0x0] [url = https://example.com/browser/toolkit/components/passwordmgr/test/browser/form_basic.html?username=username&password=password]
[task 2019-10-10T23:37:00.856Z] 23:37:00 INFO - GECKO(1965) | --DOMWINDOW == 1 (0x141b49800) [pid = 1977] [serial = 106] [outer = 0x0] [url = https://example.com/browser/toolkit/components/passwordmgr/test/browser/form_basic.html?username=newUsername&password=password]
[task 2019-10-10T23:37:00.856Z] 23:37:00 INFO - GECKO(1965) | --DOMWINDOW == 0 (0x141abd000) [pid = 1977] [serial = 110] [outer = 0x0] [url = https://example.com/browser/toolkit/components/passwordmgr/test/browser/form_basic.html?username=newUsername&password=password]
[task 2019-10-10T23:37:00.858Z] 23:37:00 INFO - [1962, Main Thread] WARNING: 'result.isErr()', file /builds/worker/workspace/build/src/startupcache/StartupCache.cpp, line 173
[task 2019-10-10T23:37:00.911Z] 23:37:00 INFO - GECKO(1965) | ++DOCSHELL 0x1333df800 == 11 [pid = 1965] [id = {768422eb-e433-a74f-b03a-d0dd558a6102}]
[task 2019-10-10T23:37:00.911Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 27 (0x13378d020) [pid = 1965] [serial = 60] [outer = 0x0]
[task 2019-10-10T23:37:00.911Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 28 (0x131625000) [pid = 1965] [serial = 61] [outer = 0x13378d020]
[task 2019-10-10T23:37:00.951Z] 23:37:00 INFO - GECKO(1965) | MEMORY STAT | vsize 7723MB | residentFast 398MB | heapAllocated 168MB
[task 2019-10-10T23:37:00.951Z] 23:37:00 INFO - TEST-OK | toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js | took 284ms
[task 2019-10-10T23:37:00.952Z] 23:37:00 INFO - GECKO(1965) | ++DOCSHELL 0x10a657000 == 3 [pid = 1969] [id = {9c83c545-be36-cc4c-86cf-2822f764438e}]
[task 2019-10-10T23:37:00.952Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 16 (0x11c34af20) [pid = 1969] [serial = 172] [outer = 0x0]
[task 2019-10-10T23:37:00.952Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 17 (0x11e08fc00) [pid = 1969] [serial = 173] [outer = 0x11c34af20]
[task 2019-10-10T23:37:00.968Z] 23:37:00 INFO - GECKO(1965) | ++DOMWINDOW == 18 (0x11e2e9c00) [pid = 1969] [serial = 174] [outer = 0x11c34af20]
[task 2019-10-10T23:37:01.020Z] 23:37:01 INFO - checking window state
[task 2019-10-10T23:37:01.020Z] 23:37:01 INFO - TEST-INFO | started process screencapture
[task 2019-10-10T23:37:01.156Z] 23:37:01 INFO - TEST-INFO | screencapture: exit 0
[task 2019-10-10T23:37:01.156Z] 23:37:01 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run -

Flags: needinfo?(gbrown)

Yes, please disable, at least on osx/debug.

Flags: needinfo?(gbrown)
See Also: → 1578178
Keywords: leave-open
Whiteboard: [stockwell needswork:owner] → [stockwell disabled]
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cbdd47de480a
Disable browser_passwordmgr_switchtab.js on mac debug for frequent failures r=gbrown
Status: REOPENED → NEW
Flags: needinfo?(MattN+bmo)
Priority: P5 → P3

We should also rename this test since I believe the browser_passwordmgr_ prefix is supposed to be for passwordManager.xul tests but this isn't one.

Summary: Intermittent toolkit/components/passwordmgr/test/browser/browser_passwordmgr_switchtab.js | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run - → Intermittent toolkit/components/passwordmgr/test/browser/{browser_basicAuth_switchTab.js,browser_passwordmgr_switchtab.js} | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run -
Summary: Intermittent toolkit/components/passwordmgr/test/browser/{browser_basicAuth_switchTab.js,browser_passwordmgr_switchtab.js} | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run - → Intermittent toolkit/components/passwordmgr/test/browser/<anything> | Found an unexpected unknown window with document URI: about:blank and title: at the end of test run -
Duplicate of this bug: 1632562
Duplicate of this bug: 1632760
You need to log in before you can comment on or make changes to this bug.