Re-enable test_background_video_resume_after_end_show_last_frame.html

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P3
normal
Rank:
25
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 months ago

The bug is created by Bug 1529500 Comment 15.

The test expects that video is visible. The test needs to wait until the video becomes visible.

Assignee

Updated

4 months ago
Assignee: nobody → sotaro.ikeda.g
Assignee

Comment 1

4 months ago

When we did not wait that the video became visible, MediaDecoder::SetElementVisibility() update the element visibility during seeking. It caused the test failure.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=57a12cddbc995bf177da510d7e6c11080c3c24c2

Assignee

Comment 3

4 months ago

attachment 9046609 [details] addressed test failure during enabling test_background_video_resume_after_end_show_last_frame.html.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9dac9bb724ef23b5f19ef9c5d3801e01cdaeb88f

Updated

4 months ago
Rank: 25
Priority: -- → P3
Assignee

Updated

4 months ago
See Also: → 1516043

Comment 5

3 months ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/341088b5783b
Re-enable test_background_video_resume_after_end_show_last_frame.html r=jya

Comment 6

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.