Closed Bug 1530625 Opened 10 months ago Closed 10 months ago

[CSD] Enable system titlebar by default for X.org sessions

Categories

(Core :: Widget: Gtk, enhancement, P2)

67 Branch
Unspecified
Linux
enhancement

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 + verified
firefox67 --- verified

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

Due to discovered regressions in mutter compositor (Bug 1530252) and Gtk+ (Bug 1525850) we need to revert the default hidden titlebar for X.org Gnome sessions to keep Firefox usable.

The system titlebar can stay disabled for Wayland/XWayland gnome sessions.

Priority: P3 → P2
  • Detect current desktop session and disable shape mask on Mutter/X.org due to Bug 1530252 (mutter bug).
  • Use system titlebar on Mutter/X.org as we can't draw the titlebar reliably.
  • Remove widget.default-hidden-titlebar from prefs. When it's defined it overrides default titlebar detection heuristics now.
  • Don't use shape masks at all on Mutter/x.org. When system titlebar is hidden in this case (by user choice) it has opaque corners unless
    argb visual is selected.
  • Use Window manager decorations on Gnome Classic session, that works better than client decorations.
Keywords: checkin-needed

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dbf19d736413
Enable system titlebar on Gnome/X.org sessions due mutter Bug 1530625 and disable titlebar X shape mask on mutter/X.org, r=lsalzman

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Can you request beta uplift? thanks.

Flags: needinfo?(stransky)
https://hg.mozilla.org/projects/oak/rev/dbf19d7364137fd04c36f04086f3445c020d2c99
Bug 1530625 - Enable system titlebar on Gnome/X.org sessions due mutter Bug 1530625 and disable titlebar X shape mask on mutter/X.org, r=lsalzman

Comment on attachment 9046661 [details]
Bug 1530625 - Enable system titlebar on Gnome/X.org sessions due mutter Bug 1530625 and disable titlebar X shape mask on mutter/X.org, r=lsalzman

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1521012
  • User impact if declined: Due to X.org/Gtk+ bugs we can't use shape masks introduced in Bug 1521012 for Firefox titlebar rendering on X.org sessions so disable the shape mask there.
    Also use system titlebar by default in those systems. When user disables system titlebar at Customize -> Title bar, Firefox may render some graphics artifacts (white/black window corners) due to disabled shape masks.

The artifacts can be fixed by:

  • running on Wayland/XWayland
  • setting mozilla.widget.use-argb-visuals to true
  • enabled HW acceleration/WebRender
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Run gnome on X.org (not on a Wayland session), create a clear profile. Run Firefox and check that the system titlebar is enabled by default. When you disable system titlebar (Customize -> Title bar) you may see gfx artifacts on top window corners. Please make sure the Firefox window is resizable by mouse cursor.
  • List of other uplifts needed: Bug 1529713
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Linux/Gtk+ only. Reverts the state to what we have in Firefox 65 for majority of Linux users which are running on X.org sessions.
  • String changes made/needed:
Flags: needinfo?(stransky)
Attachment #9046661 - Flags: approval-mozilla-beta?

Comment on attachment 9046661 [details]
Bug 1530625 - Enable system titlebar on Gnome/X.org sessions due mutter Bug 1530625 and disable titlebar X shape mask on mutter/X.org, r=lsalzman

More GTK title bar fixes. OK for beta 13.

Attachment #9046661 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Reproduced this bug using Ubuntu 18.04 x64, on an affected Nightly build (2019-02-26) and by following the steps from comment 7.

I can confirm that the title bar is enabled by default on the latest builds: Beta 66.0b13 and Nightly 67.0a1. Also, confirming that Firefox window can be resized with the mouse cursor.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Noticed some performance improvements on Linux! \0/

== Change summary for alert #19676 (as of Wed, 27 Feb 2019 07:29:27 GMT) ==

Improvements:

6% tart linux64 pgo e10s stylo 1.66 -> 1.57
4% ts_paint linux64 pgo e10s stylo 399.46 -> 383.42
3% sessionrestore linux64 pgo e10s stylo 331.12 -> 319.92

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=19676

(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #11)

Noticed some performance improvements on Linux! \0/

== Change summary for alert #19676 (as of Wed, 27 Feb 2019 07:29:27 GMT) ==

Improvements:

6% tart linux64 pgo e10s stylo 1.66 -> 1.57
4% ts_paint linux64 pgo e10s stylo 399.46 -> 383.42
3% sessionrestore linux64 pgo e10s stylo 331.12 -> 319.92

For up to date results, see:
https://treeherder.mozilla.org/perf.html#/alerts?id=19676

This is caused by delayed icon loading - Bug 1521039.

Regressions: 1558065
You need to log in before you can comment on or make changes to this bug.