Closed Bug 1530650 Opened 1 year ago Closed 1 year ago

Add `--cap-lints allow` to RUSTFLAGS when branching off central

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: hsivonen, Assigned: glandium)

Details

(Keywords: in-triage)

Attachments

(1 file)

At present, if one builds ESR with the current Rust nightly, the build fails because the servo directory uses #![deny(missing_docs)].

I suggest that when we branch off m-c, we add --cap-lints allow to RUSTFLAGS.

I suggest that when we branch off m-c, we add --cap-lints allow to RUSTFLAGS.

I suggest that we add --cap-lints warn to RUSTFLAGS when not building with --enable-warnings-as-errors.

Assignee: nobody → mh+mozilla

Unfortunately, the patch is not upliftable to esr60 because it depends on bug 1513009.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/7a5f5a8174f7
Add --cap-lints warn to RUSTFLAGS when not building with --enable-warnings-as-errors. r=froydnj

Comment on attachment 9066580 [details]
Bug 1530650 - Add --cap-lints warn to RUSTFLAGS when not building with --enable-warnings-as-errors.

Beta/Release Uplift Approval Request

  • User impact if declined: Future possible build failures with newer versions of the rust compiler during the ESR68 cycle.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only changes the way rust compiler lints are handled, which doesn't change the code compiled or how it's compiled.
  • String changes made/needed: N/A
Attachment #9066580 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9066580 [details]
Bug 1530650 - Add --cap-lints warn to RUSTFLAGS when not building with --enable-warnings-as-errors.

avoid downstream build failures during 68's lifetime, approved for 68.0b5

Attachment #9066580 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.