Debug assert in plane_split::polygon::Polygon::split_with_normal

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: nical, Assigned: nical)

Tracking

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 months ago

I'm hitting the assertion in split_with_normal that checks that t is within epsilon of the [0..1] range, after the intersection test.

t = 1.0000000000000009

I can reliably reproduce this on https://keithclark.co.uk/labs/css-fps/nojs/ with a debug build.

Assignee

Comment 1

4 months ago

According to gdb, t is a f64, for which epsilon is 2.2204460492503131e-16_f64.
Unfortunately, with generic math code in rust it's a bit awkward to write "5 * epsilon" because you first have to craft that "5" unless we want to add another trait bound to the mix like From<f64>.

Comment 3

4 months ago
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/860d0c16a0fc
Update plane-split to 0.13.7. r=kvark

Comment 4

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → nical.bugzilla
You need to log in before you can comment on or make changes to this bug.