Closed Bug 1530823 Opened 8 months ago Closed 8 months ago

Permafailing devtools/client/inspector/boxmodel/test/browser_boxmodel_jump-to-rule-on-hover.js | Test timed out - Gecko 67 merges to beta on 2019-03-11

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67+ verified)

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 + verified

People

(Reporter: nataliaCs, Assigned: mtigley)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]:
Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f6eef58baf63ab14ea1241924bb220f990a31be8&searchStr=devtools&group_state=expanded

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230620175&repo=try&lineNumber=1818

task 2019-02-26T20:36:11.506Z] 20:36:11 INFO - TEST-START | devtools/client/inspector/boxmodel/test/browser_boxmodel_jump-to-rule-on-hover.js
[task 2019-02-26T20:36:12.151Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
[task 2019-02-26T20:36:12.171Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2019-02-26T20:36:12.233Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2019-02-26T20:36:12.250Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2019-02-26T20:36:12.327Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_GRIDS"
[task 2019-02-26T20:36:12.329Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2019-02-26T20:36:12.337Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2019-02-26T20:36:12.357Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2019-02-26T20:36:12.385Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "CLEAR_FLEXBOX"
[task 2019-02-26T20:36:12.444Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_OFFSET_PARENT"
[task 2019-02-26T20:36:12.445Z] 20:36:12 INFO - GECKO(1446) | console.log: "[DISPATCH] action type:" "UPDATE_LAYOUT"
[task 2019-02-26T20:36:56.556Z] 20:36:56 INFO - TEST-INFO | started process screentopng
[task 2019-02-26T20:36:57.108Z] 20:36:57 INFO - TEST-INFO | screentopng: exit 0
[task 2019-02-26T20:36:57.111Z] 20:36:57 INFO - Buffered messages logged at 20:36:11
[task 2019-02-26T20:36:57.113Z] 20:36:57 INFO - Entering test bound
[task 2019-02-26T20:36:57.119Z] 20:36:57 INFO - Adding a new tab with URL: data:text/html,%3Cstyle%3E%0A%20%20%20%20%23box%20%7B%0A%20%20%20%20%20%20margin%3A%205px%3B%0A%20%20%20%20%7D%0A%20%20%3C%2Fstyle%3E%0A%20%20%3Cdiv%20id%3D%22box%22%3E%3C%2Fdiv%3E
[task 2019-02-26T20:36:57.120Z] 20:36:57 INFO - Tab added and finished loading
[task 2019-02-26T20:36:57.121Z] 20:36:57 INFO - Opening the inspector
[task 2019-02-26T20:36:57.122Z] 20:36:57 INFO - Opening the toolbox
[task 2019-02-26T20:36:57.126Z] 20:36:57 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,%3Cstyle%3E%0A%20%20%20%20%23box%20%7B%0A%20%20%20%20%20%20margin%3A%205px%3B%0A%20%20%20%20%7D%0A%20%20%3C%2Fstyle%3E%0A%20%20%3Cdiv%20id%3D%22box%22%3E%3C%2Fdiv%3E" line: 0}]
[task 2019-02-26T20:36:57.130Z] 20:36:57 INFO - Buffered messages logged at 20:36:12
[task 2019-02-26T20:36:57.130Z] 20:36:57 INFO - Toolbox opened and focused
[task 2019-02-26T20:36:57.131Z] 20:36:57 INFO - Selecting the layoutview sidebar
[task 2019-02-26T20:36:57.132Z] 20:36:57 INFO - Selecting the node for '#box'
[task 2019-02-26T20:36:57.133Z] 20:36:57 INFO - Test that hovering over margin-top value highlights the property in rules view.
[task 2019-02-26T20:36:57.138Z] 20:36:57 INFO - Wait for mouse to hover over margin-top element.
[task 2019-02-26T20:36:57.138Z] 20:36:57 INFO - Buffered messages finished
[task 2019-02-26T20:36:57.139Z] 20:36:57 INFO - TEST-UNEXPECTED-FAIL | devtools/client/inspector/boxmodel/test/browser_boxmodel_jump-to-rule-on-hover.js | Test timed out -
[task 2019-02-26T20:36:57.140Z] 20:36:57 INFO - GECKO(1446) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn8.child1/context22' can't be sent as the connection is closed."
[task 2019-02-26T20:36:57.141Z] 20:36:57 INFO - Removing tab.
[task 2019-02-26T20:36:57.144Z] 20:36:57 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-02-26T20:36:57.145Z] 20:36:57 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-02-26T20:36:57.146Z] 20:36:57 INFO - Tab removed and finished closing
[task 2019-02-26T20:36:57.150Z] 20:36:57 INFO - GECKO(1446) | MEMORY STAT | vsize 704MB | residentFast 319MB | heapAllocated 93MB
[task 2019-02-26T20:36:57.152Z] 20:36:57 INFO - TEST-OK | devtools/client/inspector/boxmodel/test/browser_boxmodel_jump-to-rule-on-hover.js | took 45345ms

Flags: needinfo?(mtigley)

I'm unable to reproduce these failing tests both locally and when I push to try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=130d4d282d1165d9a060f713dcdeab5b85cbf0a1

Is there a specific try command I can use to replicate the conditions the results above are using?

Flags: needinfo?(mtigley) → needinfo?(ncsoregi)
Assignee: nobody → mtigley
Priority: -- → P2

This feature is hidden behind a pref and is only enabled in Nightly, so we should be able to use pushPref to fix this issue.

Flags: needinfo?(ncsoregi)
Status: NEW → ASSIGNED
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/458fef0de61d
Use pushPref to temporarily enable highlighting boxmodel properties in tests. r=gl
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.