Closed Bug 1530834 Opened 1 year ago Closed 1 year ago

[wpt-sync] Sync PR 15522 - [Azure Pipelines] Put artifact name in urlencoded POST body

Categories

(Testing :: web-platform-tests, enhancement, P4)

enhancement

Tracking

(firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: wptsync, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream error])

Sync web-platform-tests PR 15522 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/15522
Details from upstream follow.

Philip Jägenstedt <philip@foolip.org> wrote:

[Azure Pipelines] Put artifact name in urlencoded POST body

... instead of in the query string. This will probably resolve the
"POST requests require a Content-length header" problem [1] assuming
that the cause is a version of curl that doesn't send the header if
the request has no body.

[1] https://dev.azure.com/web-platform-tests/wpt/_build/results?buildId=7671

Whiteboard: [wptsync downstream] → [wptsync downstream error]
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/975fbec5a080
[wpt PR 15522] - [Azure Pipelines] Put artifact name in urlencoded POST body, a=testonly
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/70fc9e4d62dd
[wpt PR 15522] - [Azure Pipelines] Put artifact name in urlencoded POST body, a=testonly
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.