Popup notification fails to re-appear in some cases in QuantumBar

RESOLVED FIXED in Firefox 67

Status

()

defect
P2
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: standard8, Assigned: mak)

Tracking

(Blocks 3 bugs)

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Reporter

Description

3 months ago

Running on try server, part 4 of browser_popupNotification_no_anchors.js is currently failing with a timeout.

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230725200&repo=try&lineNumber=2563

I could reproduce this test locally with QuantumBar, but not the existing address bar.

STR:

  1. Visit https://www.w3schools.com/html/html5_geolocation.asp
  2. Click the "Try It" button near the top.
  3. Click in the address bar and type "*"

-> The popup disappears as expected.

  1. Press backspace
  2. Press Tab

Expected Results

=> The popup appears again

Actual Results

=> The popup doesn't appear

Assignee

Comment 1

3 months ago

It looks like our focus/blur handlers are incomplete.

Assignee: nobody → mak77
Status: NEW → ASSIGNED

Comment 3

2 months ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/be438ca69c7e
Popup notification don't re-appear when QuantumBar blurs. r=Standard8

Comment 4

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.