Closed Bug 1531044 Opened 8 months ago Closed 8 months ago

Python error when trying to install host utils for android testing

Categories

(Firefox Build System :: Mach Core, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1530846

People

(Reporter: kats, Assigned: gbrown)

References

Details

Attachments

(1 file)

$ ./mach mochitest gfx/layers/apz/test/mochitest/test_group_zoom.html 
No Android devices connected. Start an emulator? (Y/n) y
Starting emulator running Android 7.0 x86...
accel:
0
KVM (version 12) is installed and usable.
accel
Running the x86 emulator; be sure to install an x86 APK!
Your host utilities are out of date!
You have host-utils-61.0a1.en-US.linux-x86_64 installed, but host-utils-66.0a1.en-US.linux-x86_64 is available
Update host utilities? (Y/n) y
Installing host utilities. This may take a while...
Error running mach:

    ['mochitest', 'gfx/layers/apz/test/mochitest/test_group_zoom.html']

The error occurred in mach itself. This is likely a bug in mach itself or a
fundamental problem with a loaded module.

Please consider filing a bug against mach by going to the URL:

    https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox%20Build%20System&component=Mach%20Core


If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'Module_six_moves_urllib' object has no attribute 'urlopen'

  File "/home/kats/zspace/gecko-fennec/python/mach/mach/main.py", line 359, in run
    return self._run(argv)
  File "/home/kats/zspace/gecko-fennec/python/mach/mach/main.py", line 414, in _run
    args = parser.parse_args(argv)
  File "/usr/lib/python2.7/argparse.py", line 1701, in parse_args
    args, argv = self.parse_known_args(args, namespace)
  File "/usr/lib/python2.7/argparse.py", line 1733, in parse_known_args
    namespace, args = self._parse_known_args(args, namespace)
  File "/usr/lib/python2.7/argparse.py", line 1942, in _parse_known_args
    stop_index = consume_positionals(start_index)
  File "/usr/lib/python2.7/argparse.py", line 1898, in consume_positionals
    take_action(action, args)
  File "/usr/lib/python2.7/argparse.py", line 1807, in take_action
    action(self, namespace, argument_values, option_string)
  File "/home/kats/zspace/gecko-fennec/python/mach/mach/dispatcher.py", line 172, in __call__
    if handler.parser:
  File "/home/kats/zspace/gecko-fennec/python/mach/mach/decorators.py", line 76, in parser
    self._parser = self._parser()
  File "/home/kats/zspace/gecko-fennec/testing/mochitest/mach_commands.py", line 255, in setup_argument_parser
    verify_android_device(build_obj, install=False, xre=True)
  File "/home/kats/zspace/gecko-fennec/testing/mozbase/mozrunner/mozrunner/devices/android_device.py", line 288, in verify_android_device
    _maybe_update_host_utils(build_obj)
  File "/home/kats/zspace/gecko-fennec/testing/mozbase/mozrunner/mozrunner/devices/android_device.py", line 166, in _maybe_update_host_utils
    _install_host_utils(build_obj)
  File "/home/kats/zspace/gecko-fennec/testing/mozbase/mozrunner/mozrunner/devices/android_device.py", line 106, in _install_host_utils
    _tooltool_fetch()
  File "/home/kats/zspace/gecko-fennec/testing/mozbase/mozrunner/mozrunner/devices/android_device.py", line 867, in _tooltool_fetch
    _download_file(TOOLTOOL_URL, 'tooltool.py', EMULATOR_HOME_DIR)
  File "/home/kats/zspace/gecko-fennec/testing/mozbase/mozrunner/mozrunner/devices/android_device.py", line 830, in _download_file
    f = urllib.urlopen(url)

Probably regression from bug 1428714

Blocks: 1428714
Flags: needinfo?(hutusoru.andrei)

Also ni? davehunt since it appears that was a mentored bug.

Flags: needinfo?(dave.hunt)
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(hutusoru.andrei)
Flags: needinfo?(dave.hunt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1530846
Component: Mozbase → Mach Core
Product: Testing → Firefox Build System
Version: Version 3 → unspecified
You need to log in before you can comment on or make changes to this bug.