Some links still refer to readthedocs

RESOLVED FIXED in Firefox 67

Status

defect
P1
normal
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: philscrace, Assigned: whimboo)

Tracking

Trunk
mozilla67
Unspecified
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

4 months ago

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.109 Safari/537.36

Steps to reproduce:

Navigate from a browser to

a. https://marionette-client.readthedocs.io/en/master/reference.html

also links are broken in the section called 'Using Marionette' at this link here:

https://firefox-source-docs.mozilla.org/testing/marionette/marionette/Intro.html

explictly these:

Download and setup the Python client for Marionette
Run Tests with Python – How to run tests using the Python client
You might want to experiment with using Marionette interactively at a Python command prompt
Start writing and running tests
Tips on debugging Marionette code
Protocol definition

Actual results:

Documentation and Marionette manual is not available

Expected results:

Reference manual is accessible and readable

Comment 1

4 months ago

Hi,

I can reproduce this issue, those links lead to a page which says "SORRY - This page does not exist yet."
I'm going to add the component in order to involve the development team in reviewing this issue.

Thank you for reporting!

Status: UNCONFIRMED → NEW
Component: Untriaged → Marionette
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Testing
Version: 67 Branch → Trunk

The API documentation was moved to
https://firefox-source-docs.mozilla.org/python/marionette_driver.html,
following the announcement that marionette_driver is being deprecated:
https://lists.mozilla.org/pipermail/tools-marionette/2019-January/000068.html

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Cannot access Marionette online Reference manual/docs and others → Links on Intro.md are broken

Actually I will re-use this bug to fix the links in Intro.html.

Assignee: nobody → ato
Status: REOPENED → ASSIGNED
Priority: -- → P1

As discussed with Andreas on IRC I will fix it.

Assignee: ato → hskupin
Summary: Links on Intro.md are broken → Some links still refer to readthedocs
Blocks: 1530794

Interesting we have two working documentation instances for Marionette:

https://firefox-source-docs.mozilla.org/testing/marionette/marionette/Intro.html
https://firefox-source-docs.mozilla.org/testing/marionette/Intro.html

While the former (and outdated) link contains the wrong URLs, the latter and to-be-used documentation has the fix.

So it looks like that due to some reason formerly generated documentation is not getting removed when moved to a different location.

Andrew, can you please have a look why this happens?

With this bug I will only cover the remaining real instances as listed here:
https://searchfox.org/mozilla-central/search?q=marionette-client&path=

Flags: needinfo?(ahal)

I currently cannot push the changes to inbound because the tree is closed due to infra issues (bug 1532254). I will try later.

(In reply to Henrik Skupin (:whimboo) [⌚️UTC+1] (away 02/28 - 03/03) from comment #5)

Interesting we have two working documentation instances for Marionette:

https://firefox-source-docs.mozilla.org/testing/marionette/marionette/Intro.html
https://firefox-source-docs.mozilla.org/testing/marionette/Intro.html

While the former (and outdated) link contains the wrong URLs, the latter and to-be-used documentation has the fix.

So it looks like that due to some reason formerly generated documentation is not getting removed when moved to a different location.

So this is actually bug 1526796. The Marionette documentation was moved by bug 1523962. As such it is out of scope for this bug.

Flags: needinfo?(ahal)

Comment 9

4 months ago
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/559e8b22fdc5
[marionette] Remove remaining links to readthedocs from client documentation. r=me

Comment 10

4 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/15717 for changes under testing/web-platform/tests
Upstream PR merged
You need to log in before you can comment on or make changes to this bug.