Pop-up windows get corrupted on scroll if they have no status bar

VERIFIED FIXED in Chimera0.5

Status

Camino Graveyard
Page Layout
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: david scotson, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({testcase})

unspecified
Chimera0.5
PowerPC
Mac OS X
testcase

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    20020618

if you go to www.theonion.com, several of the links cause pop up windows to appear. The Javascript command window.open is used to adjust the new windows settings including hiding the status bar. If you shrink the window to get a vertical scrollbar and then scroll down the window displays artifacts in the form of horizontal lines of garbage.

Reproducible: Always

Steps to Reproduce:
1. open a window using the following code (e.g. the ones at theonion.com) onclick="window.open('destination.html','test','status=no')"
2.resize the window till it is too small vertically and scrollbars appear
3.scroll down

Actual Results:  
horizontal lines of distortion should be visible

Expected Results:  
horizontal lines of distortion should not be visible

there is a number of settings on the www.theonion.com page but I have narrowed it down to 'status=no' being the trigger.

Comment 1

16 years ago
Confirming issue with the june 20th (2002-06-20-05 NB).

Comment 2

16 years ago
http://mozilla.org/quality/browser/standards/html/script.html


Link in test case creates a JS window (window.open) using the following function:

 function popup() {
myWindow =window.open("water.html","popup","width=400,height=247");
myWindow.location ="water.html";


When scrolling the window, you should see the painting issue on the bottom part
of image.
Keywords: testcase

Comment 3

16 years ago
Looks like it isn't updating a strip of the window, possibly because it still
thinks the horizontal scroll bar or status bar should be there.

Comment 4

16 years ago
Confirmed using Chimera/20020621. Interestingly, Mozilla doesn't even show
scrollbars on the example Chris mentioned.
Summary: pop up windows get corrupted on scroll if they have no status bar → Pop-up windows get corrupted on scroll if they have no status bar

Comment 5

16 years ago
->pinkerton, scrolling invalidation code in a popup window isn't working
Assignee: saari → pinkerton
(Assignee)

Comment 6

16 years ago
damnit
Status: NEW → ASSIGNED
Target Milestone: --- → Chimera0.5

Comment 7

16 years ago
*** Bug 155896 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 156029 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
*** Bug 156823 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 154286

Comment 10

16 years ago
*** Bug 158821 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 160956 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
lots of dupes... we should fix this
(Assignee)

Comment 13

16 years ago
per winnie's request, fixed ;)
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
gorgeous!  verified with 08-09 build on OS 01.1.5.
Status: RESOLVED → VERIFIED

Updated

16 years ago
No longer blocks: 154286
You need to log in before you can comment on or make changes to this bug.