Closed Bug 1531160 Opened 2 years ago Closed 2 years ago

Install hashes reduced to 15 chars

Categories

(Toolkit :: Application Update, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox67 --- verified

People

(Reporter: heftig, Assigned: robert.strong.bugs)

References

Details

Attachments

(1 file)

My install hash suddenly has only 15 characters instead of 16. As a result, it insisted on a fresh profile.

I suspect bug 1530560, which falls into the regression range (7c89a561baee works, 5b8896aa3f69 is broken), has introduced a off-by-one error.

When you say install hash are you referring to your Firefox profile?

Flags: needinfo?(jan.steffens)

I'm referring to installs.ini, which now looks like this (after I replaced the new profile with my existing one):

[334CB573D1216F2]
Default=x0jp7kki.default
Locked=1

[334CB573D1216F23]
Default=x0jp7kki.default
Locked=1
Flags: needinfo?(jan.steffens)
Summary: Install hashes reduced to 11 chars → Install hashes reduced to 15 chars
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2624b1bdee9b
Add the original NS_tsnprintf and use a new name for the new function. r=mhowell
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → robert.strong.bugs
Duplicate of this bug: 1531227

I've verified that the install hashes have returned to 16 chars (custom 98d4803bb2de as well as official build 20190228214753).

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1531799
You need to log in before you can comment on or make changes to this bug.