Closed Bug 1531226 Opened 2 years ago Closed 1 year ago

PiP player does not stay on top for macOS

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

67 Branch
Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox72 --- verified

People

(Reporter: mb8672, Assigned: mconley)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Right click YouTube video player twice and selected "Picture in Picture"

I didn't see a bug associated with this activity unless its obscured under a technical term I'm not hitting in search.

Actual results:

Player opened up in right corner but upon moving to another site or clicking an element within the current page, the player vanishes under all the other windows.

Expected results:

The player should have stayed on top of Firefox.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit
Blocks: videopip
Priority: -- → P1

I think this should be P3 for now. It's a known issue that alwaysOnTop isn't working for macOS and Linux, and isn't going to block us shipping this on Windows.

OS: Unspecified → macOS
Priority: P1 → P3
Depends on: 1532103
Duplicate of this bug: 1532130
Blocks: 1532675
No longer blocks: videopip
Summary: PiP player does not stay on top → PiP player does not stay on top for macOS
No longer depends on: 1532103
Status: UNCONFIRMED → NEW
Ever confirmed: true
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa3070ca5599
Add support for alwaysontop windows for macOS. r=mstange
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Duplicate of this bug: 1593631
Flags: qe-verify+

Hello, reproduced the issue using Firefox 67.0a1 (20190227163104) on macOS 10.15.
The issue is verified fixed with Firefox 72.0b5 (20191210230245) on macOS 10.15. The PiP player stays on top after clicking somewhere on the page.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.