Closed Bug 1531259 Opened 7 months ago Closed 7 months ago

Size of button which opens inspector will be changed by the label length

Categories

(DevTools :: Inspector: Animations, enhancement, P2)

enhancement

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: daisuke, Assigned: daisuke)

Details

Attachments

(2 files, 1 obsolete file)

Attached image inspect-button-size.png

The size of button which opens inspector will be changed by the label length like as a screenshot I attached.

I investigated a bit, this was caused by this change on reps, especially padding: 0;.

I don't know the reason exactly yet, the button size will be shrinkked if padding is 0 by flex layout.
This will be fixed by setting flex-shrink: 0; to the button in animation.css.

Status: NEW → ASSIGNED

Depends on D21638

Attachment #9047583 - Attachment is obsolete: true
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d76e6e7025c
Avoid to shrink buttons open inspector. r=pbro
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.