Sea monkey freezes when trying to save email attachment

UNCONFIRMED
Unassigned

Status

defect
UNCONFIRMED
4 months ago
4 months ago

People

(Reporter: alan, Unassigned)

Tracking

SeaMonkey 2.49 Branch
Unspecified
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 months ago

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

Steps to reproduce:

Received email with attachments. Double clicked attachment ( which should save it by default)

This appears to have started a few weeks ago. Sea Monkey running on Win 7 x64, fully up to date with patches. It is not a space issue, disk has 83GB free and attachment was only 25kB

Actual results:

Saving dialogue starts, and gets to 99%, and then Sea Monkey freezes. File name is created in Downloads folder, but with size 0. I have to close Sea Monkey ( Red X in corner, or Task Manager). Restart it and it works OK.

Expected results:

Saving dialogue should start, get to 100% resulting in file stored in Downloads folder. File save window should close and I carry on

Comment 1

4 months ago

Not a known bug for me. https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1531292&sharer_id=41036 does not show obvious DUPs

@reporter:
Please forward that Email to me, so that I can try to reproduce that problem. I will keep contents confidential.

Flags: needinfo?(alan)
OS: Unspecified → Windows 7

Updated

4 months ago
Component: General → MailNews: General
Reporter

Comment 2

4 months ago

Copy email with attachments forwarded direct a few minutes ago.

OS = Win 7 x64, fully patched.

Flags: needinfo?(alan)
Reporter

Comment 3

4 months ago

I should have added:-

This has happened with several emails, the one forwarded was just the latest example.

It also only seems to happen the first time each day that I try saving an attachment. When SM is restarted after the failure, it usually saves the attachment without any problems, and the issue does not recur until the PC has been rebooted. I do not see it as a boot-time issue as the PC will typically have been on for 5 minutes or more before I check my emails.

Comment 4

4 months ago

NOT reproducible with installation of unofficial (by wg9s) en-US SeaMonkey 2.53 (NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20190211152201 (Default Classic Theme, German Language Pack active) on German WIN7 64bit
and
Forwarded Email from Reporter.

I tried 'Rightclick on Attachment in Email (att-pane) → Save as' for email attachments one by one in a newly created folder and also 'Rightclick on Attachment in Email → Save all' into an existing folder, both worked fine without any problems.

@reporter:
Can you try in safe mode ('Help → ...') with disabled add-ons?

Reporter

Comment 5

4 months ago

Thanks.

I tried in Safe mode, and it froze again.

I thought that I would try to get additional diagnostics, so closed SM, and started Process Monitor ( from Sysinternals). I then started SM again, but could not reproduce the fault with Process Monitor running. I tried SM in normal and SM in Safe mode.

This is an intermittent fault. As mentioned above, it tends to happen only after a reboot of PC. Most of the time the attachments just save correctly.

Can we leave it open for a few days and I will try and get more diagnostics when it recurs.

Reporter

Comment 6

4 months ago

I have now managed to reproduce this, with Process Monitor running. I have the complete log file if required, but it is about 40MB.

Looking at the processing, and ignoring many steps, the flow seems to be:-

1 When I click the attachment, a download file is created in f:\Users\Alan\appdata\local\temp\02aYHnOI.pdf.part

2 This file is created and has the correct size and can be read by a pdf reader program

3 It then creates the correct filename in f:\users\alan\downloads

4 It then closes the file in \appdata\local\temp and a) fails to copy the content to \downloads, and b) does not clean up the .pdf.part file in \temp

5 SM then goes "Not responding" in Task Manager and has to be closed to continue.

If you want the full log file, please advise and I will upload it.

Reporter

Comment 7

4 months ago

Just had it happen again on a new email.

One thought, all the recent occurrences have been with mail and attachments which were created on an Apple Mac, I am running on Windows. I don't know if this could be relevant.

Could you turn off you antivirus when trying to save the file.

There is a known problem in 2.49.4 on macOS but it does not apply to Windows.

Rainer: 2.53 has a new download backend so this might be 2.49 specific.

Reporter

Comment 9

4 months ago

I tried turning my Anti Virus off, and saving the attachment, and it worked without any problems. However, I do not see this as conclusive as I have had other recent attachments which have saved without problems. Indeed, when the problem does occur, after a restart, SM usually saves the attachment without any problem. It is only intermittent and I would not consider downloading attachments normally without some kind of AV shield.

Probably hard to track down. 2.49.5 is in the works but a slow go because of a new infrastructure. You can try the unofficial version at http://www.wg9s.com/comm-esr/ but I am not sure it will do anything here.

Reporter

Comment 11

4 months ago

It is more of an annoyance than a major bug. Perhaps we leave this topic up to ensure that there is a suitable test case for future releases and wait and see if it is OK in the next version. I do not recall the problem when I first started using 2.49.4, so it is probably an external change that has caused it, whether AV software, Windows updates or something else.

You need to log in before you can comment on or make changes to this bug.