Middle click on a history in menubar fails to open page in new tab

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: alice0775, Assigned: Gijs)

Tracking

({nightly-community, regression})

67 Branch
Firefox 67
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67+ verified)

Details

Attachments

(1 attachment)

Reporter

Description

4 months ago

[Tracking Requested - why for this release]: Middle click on a history in menubar is broken

Reproducible: always:

Steps to reproduce:

  1. Enable menu bar
  2. Open History menu in the menu bar
  3. Middle click a history to open it in new tab

Actual results:
Fails to open the history. But open incorrect url like "place:sort=4&maxResults=15"

Expected results:
Should open the history in new tab

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=67fac975c2f81c99e40b137f9c41bba8c1cb4d85&tochange=56e28681fc9bb2995e2e53d0c0030451c03d4bd6

Regressed by: 56e28681fc9b Jonas Allmann — Bug 1523813, Remove new Function from utilityOverlay.js, r=Gijs

:jallmann, your patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(jallmann)
Reporter

Updated

4 months ago
Has Regression Range: --- → yes
Has STR: --- → yes

Gijs, can you weigh in on how hard it would be to fix that regression? Jonas is on PTO this week, he will be back early next week. If it's a longer fix, then potentially we have to backout the change from Bug 1523813. What's your take?

Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Comment 2

4 months ago

(In reply to Christoph Kerschbaumer [:ckerschb] from comment #1)

Gijs, can you weigh in on how hard it would be to fix that regression?

I don't think it should be super hard. We're using the wrong URL to try to open. We should fix the code in question to open the right URL.

Jonas is on PTO this week, he will be back early next week. If it's a longer fix, then

then we should think about uplifting. :-)

Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Updated

4 months ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(jallmann)
Assignee

Comment 4

4 months ago

Marco, I think this is just because we missed the history places menu's special _onCommand implementation. I didn't find any other _onCommand implementations that I think would be affected, but it'd be useful if you can verify that is actually true. I did also do some spot-testing of the library panel, library window and sidebars, and they seem to be fine.

Comment 5

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Priority: -- → P1
Reporter

Updated

3 months ago
Duplicate of this bug: 1535526
Flags: qe-verify+

Verified fixed on Windows 7 x64, Windows 10 x64 and Ubuntu 18.04 x64 using Firefox 67 Beta 8 (buildID: 20190404130536).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.